$(SolutionDir) not resolved correctly

Issue #6 resolved
Eugen Richter
created an issue

With the 6.3 version the path for Solution directory is not resolved correctly.

Command Script:

""$(SolutionDir)..\..\Techn_Bearb\SW\SW_Komponenten\PC-Software\Diagnose-Software\CuStOmEr\CuStOmErSetup\SolutionPostbuild.cmd" "$(SolutionDir)BuildOutput\$(Configuration)" "$(SolutionDir)..\..\Techn_Bearb\SW\SW_Komponenten\PC-Software\Diagnose-Software" "$(ConfigurationName)""

Log Output V0.6.3:

06.08.2014 10:01:32 [INFO]: cmd.exe /C ""..\..\..\..\..\..\..\Solutions\CuStOmEr Full\..\..\Techn_Bearb\SW\SW_Komponenten\PC-Software\Diagnose-Software\CuStOmEr\CuStOmErSetup\SolutionPostbuild.cmd" "..\..\..\..\..\..\..\Solutions\CuStOmEr Full\BuildOutput\Debug" "..\..\..\..\..\..\..\Solutions\CuStOmEr Full\..\..\Techn_Bearb\SW\SW_Komponenten\PC-Software\Diagnose-Software" "Debug""

Log Output V0.6.0:

06.08.2014 09:58:04 [INFO]: cmd.exe /C ""C:\Projects\CuStOmEr\Solutions\CuStOmEr Full\..\..\Techn_Bearb\SW\SW_Komponenten\PC-Software\Diagnose-Software\CuStOmEr\CuStOmErSetup\SolutionPostbuild.cmd" "C:\Projects\CuStOmEr\Solutions\CuStOmEr Full\BuildOutput\Debug" "C:\Projects\CuStOmEr\Solutions\CuStOmEr Full\..\..\Techn_Bearb\SW\SW_Komponenten\PC-Software\Diagnose-Software" "Debug""

We have the following structure for our projects

<Repository Folder>
    Solutions
        Solution1
            Solution1.sln
            ...
        Solution2
            Solution2.sln
            ...
    Techn_Bearb
        <Projects in different directory depths>

Comments (6)

  1. Denis Kuzmin repo owner
    • changed status to open

    all new problems with the MSBuild after fixes bug(specific solution for MS-bug) with GlobalProjectCollection :(

    so,

    • what path if you set specific project as $(SolutionDir:project)
    • what path you see with UI-helper window for default and specific project
    ..\..\..\..\..\..\..\Solutions\CuStOmEr Full\
    C:\Projects\CuStOmEr\Solutions\CuStOmEr Full\
    

    problem may with the new filled GlobalProjectCollection, because all properties should evaluates only with MSBuild engine.

    if you can, send me demo-empty solution project with your path-structures what you use in real project for debugging paths

  2. Eugen Richter reporter

    I forked your project and will try to find the bug on the real solution. I'll make pull request as soon as I found the solution.

    It's time to improve the VSIX development skills :-)

  3. Log in to comment