Issue #11 resolved

Fraps and other game recorder compatability??

Anonymous created an issue

It seems that both Fraps and MSI Afterburner are somehow hindering the activation of the 3rd word of any shout. I can get first and second words off but the 3rd shout word just never activates. Once I stop the recording, and the recorder is still active and ready to record, I can use all shouts normally and without any problem.

Comments (8)

  1. Asmodae repo owner

    As far as I know there should be no incompatibilities with recording software as long as the keybindings don't conflict.

    Recording software can sometimes be a fairly significant load the CPU. I use a controlled timing method for getting the shout key sequences into the game from WSR macros. If the CPU is heavily loaded the script timing might not be keeping up with the keystrokes.

    In the macro file you'll see a sequence of numbers inside curly braces. These values are the delays between keystrokes that the macro file inserts. Try increasing that value from 100 (milliseconds) to 150, or 200 and see if that makes a difference.

  2. seansmith52056

    I ask because I used to use Thuumic. They had a similar system where you had to add delays on the shouts if the words didn't activate. Since there are 3 lines of numbers, one for the single word, the second line for the double word shout and the 3rd line for the triple word shout, which line should I alter? Should line 3 be all 200? Or should I put in line 3 150, 175, 200?

  3. Asmodae repo owner

    Start with all three, then tune from there.

    You won't have to exit the game each time you make a change, but you do need to make sure you re-sign your macro file after each edit.

  4. seansmith52056

    I started off with all three lines at 200 and that didn't work, and then I tried the bottom two lines at 200 and it didn't work, and then I tried the third line at all 200 and it did work. I tried a few variations with some of the first words at lower numbers and the 2nd and 3rd words at higher numbers and still nothing. I went as high as 225 or 250 but that seemed too high.

    So then I started considering what you mentioned about the CPU not being able to catch up to the keystrokes of the mod and so I began working backwards. I opened up Steam and I re installed Skyrim because most of my 20ish mods I use (most of which are used to help boost FPS by improving textures, providing smoother animations and reassigning pixels and such from environmetal bullcrap like snow, leaves and rain) were probably needing updates. After all the pixel reassignment modding I use the texture mods. One of my favorites is Enhanced Night Skyrim. Beautiful for screenshots of the night sky!!! Climates of Tamriel is also a good one!! I also have better animal textures(the vanilla animal textures just look so bad >.<) , better armor, horse/horse armor and a few other texture based mods. I have few if ANY heavy mods that deal with animations. I have a "female walk" mod, cause hey...WE ALL LOVE WHEN DEY BOOTY SHAKIN AM I RIGHT??? >.> lol I also have an archery mod that makes the bow animation more realistic, a sheath replacer for weapons and a rogue mod called Sneak Tools. So my mod load alone probably wasnt the issue, I think I just hadn't cleaned out my Skyrim folders in a while lol

    So once I had Skyrim re-installed again, I got rid of a few mods I hadn't used in a while, and then correctly re-installed all my mods and that got it to work. The biggest mod I use of course is SkyVoice!!! And the Dance of Death!! Thats the ONLY and I mean the ONLY animation heavy mod I use lol but its something thats a part of the game already so I'd sooner call it an "add on" than a mod lol

    Anyway, this also significantly improve my frame rates and all around mod functionality so I am quite happy :) TY for your insight!! I will keep that shout delay in mind for future use though if I run into any more issues!!

  5. Asmodae repo owner

    Sweet! Glad to hear you got it working. If you post any videos using skyvoice, I'd be very glad to watch them. Feel free to post it on the nexus page.

    As for this issue on the bug tracker, I'm going to mark it closed. Thanks again and enjoy the mod!

  6. Log in to comment