pymissile /


This game is a Missile Command clone, written in Python

Main Menu

Main Menu

PyMissle in action

PyMissle in action

Running the game

In order to run PyMissle, you have to follow the following steps

Install Python

In order to build the game, you need Python 2.7

Either download Python from its website, or use your package manager to get it.

PyMissle works fine with Python 2.7 (maybe it will run on Python 3).

Install Pygame

Visit or use your package manager to get it.

Get the source!

Get the PyMissle source by cloning the PyMissle repository

$ hg clone

Run the game

You'll find a file named Running this file starts PyMissile.