Sublime hangs being caused by struct autocompletion

Issue #130 new
Axel Aguado
created an issue

Hi, I am having a serious issue.

I have a packed struct declared in a package. When I try to access members of that struct via the "." operator, sublime text hangs completely. Analyzing the process wait chain shows that the blame lies with plugin_host.exe.

My project is set up such that files are on network shares, but this has never been a problem in the past.

I also had a similar issue with tooltips causing hangs, but I don't need those as much so I simply disabled them. The dot operator autocompletion, on the other hand, is very important to me.

I'm not sure what kind of debug info I can provide. Please let me know.

Thanks for your attention!

Comments (3)

  1. Clams repo owner

    Can you share the structure (or even the whole package) which causes the issue ? It is something i'm using daily without issue, so I guess it is something specific which causes the problem. If you don't want the information to be public you can send it via mail to clams@mail.com

  2. Axel Aguado reporter

    I can't send the actual code, even over email. IT is very strict about code confidentiality.

    I will try to recreate it in a different project and get back to you. In the meantime, how can I disable the feature? every time I type a dot on a struct it hangs. :-)

  3. Clams repo owner

    Yes you can disable the auto_completion by the following line to your user settings (Menu preferences->package settings->SystemVerilog->Settings - users)

    {
    "sv.disable_autocomplete": true,
    ...
    }
    
  4. Log in to comment