configure: error: could not determine the version of the Motif library

Issue #19 new
marco bomben
created an issue

Dear all, I have tried configuring SoXt but I get the following message: {{{ configure: error: could not determine the version of the Motif library }}} while trying to install in this way: {{{ ./configure --prefix=/data/atlas/mbomben/soxt-install --with-coin=/data/atlas/mbomben/coin-install --with-motif=/data/atlas/mbomben/openmotif-install --verbose }}} According to RELEASE file of openmotif I have OpenMotif version 2.3.1: {{{ OpenMotif 2.3.1 Mon 1 September 2008 08:40:00 PM EET }}}

Am I missing something?

Many thanks in advance and regards, Marco

Comments (1)

  1. André Rummler

    Hi Marco,

    I had the same problem. At least in my case it was caused by the shared library path: - configure creates a source file conftest.cpp, compiles it and executes it (and deletes everything afterwards) - unfortunately the execution part did not work as the shared library "libCoin.so.60" was not found - Before running configure again I added the path to this library to LD_RUN_PATH: export LD_RUN_PATH=/path/to/coins-library/lib/ - suddenly everything works like a charm

    Cheers, André

  2. Log in to comment