1. Coin3D
  2. Coin
Issue #39 new

SoQt Build Error!!!!!!!!!

Anonymous created an issue

Hi,

I am trying to build SoQT in Visual Studio, I am getting this error while i am building

1>moc'ing g:\Coin3D\Coin-3.1.3\build\SoQt-1.5.0\src\Inventor\Qt\SoQtSignalThread.h 1>The system cannot find the path specified. 1>Project : error PRJ0019: A tool returned an error code from "moc'ing g:\Coin3D\Coin-3.1.3\build\SoQt-1.5.0\src\Inventor\Qt\SoQtSignalThread.h"

It is saying it can't find the path specified whereas SoQtSignalThread.h is already there inside source file when i extracted SoQT.zip file.

Please Anybody Help Me!!!!!!!!

Comments (3)

  1. A nonymous

    Hi,

    I know this topic is over a year old but I ran into the same error while compiling SoQt-1.5.0. Does anybody know what causes this error and is there any solution?

    I would like to here it. Many thanks in advance!

  2. Roy Walmsley

    Hi,

    I don't have VS2010 (or later), which is what I assume you are using. So I would like to clarify some points, please.

    Are you saying that the MOC cannot find the file "g:\Coin3D\Coin-3.1.3\build\SoQt-1.5.0\src\Inventor\Qt\SoQtSignalThread.h"? Or perhaps it cannot find one of the files that it includes? Have you correctly setup the paths to the QT files within visual studio? What is the value of your QT_VERSION define? Is QT_NO_THREAD defined?

    A quick internet search revealed other people apparently having similar issues to yours, e.g. VS2010 C++ with QT5. Is there anything useful there.

    I also noted that the corresponding cpp file has the line

    include <Inventor/Qt/moc_SoQtSignalThread.icc>

    I note that this file is not in the source so I am assuming it would be output by the MOC, if it worked. Is that correct?

    Regards,

    Roy

  3. Log in to comment