No point cloud is published

Issue #17 new
sprinkle xie created an issue


I have built the package from source and tried to run the example.launch file. But unfortunately there is no visible point cloud in rviz. Neither works it with a debian package. After checking with “rostopic echo /velodyne_points“ it said:

“WARNING: no messages received and simulated time is active.“

Have you ever met the same problem? I used to successfully used this simulator in gazebo9 but now it goes into trouble after I changed gazebo9 into gazebo7 with ROS kinetic.

Version of gazebo7 is 7.15.0. Should I use a specific version of gazebo or this plugin?

Thanks in forward!

Comments (8)

  1. Kevin Hallenbeck

    It works on my machine with gazebo 7.15.0 today. I haven’t seen this before. Is gzserver still running or has it died? Is the ROS Time still incrementing in RViz?

  2. sprinkle xie reporter

    Thanks for your reply! Gzserver is still running and the ros time is also still incrementing in RViz.

    I also tried on other computers and it did works. I have tried to reinstall gazebo7 according to instructions on the official website, but the simulator still didn’t work. Then I reinstalled gazebo7 from Ubuntu source (7.0.0+dfsg-2) instead from OSRF repository and then update it to 7.15.0 by adding repositories and key as described in Install Gazebo using Ubuntu packages , and the simulator works now anyway. I don’t know why but maybe there are some configurations wrong with ros or gazebo on my computer If no one else has such problem.

  3. Engineer

    Hello Mr. Kevin Hallenbeck,

    I followed the given instructions, however I could not publish 3d data on topic/rviz. Please guide me.

    The Gzserver is running:

    I am using Ubuntu 16.04 with gazebo7.15. I have deleted gazebo (even ROS) and reinstalled using different ways, however I could not publish topic.

  4. Maxim Rovbo

    Same problem with ROS melodic, Ubuntu 18.04.2 LTS (Kubuntu), Gazebo 9.0.0 (out of the box, not compiled from source) and the melodic velodyne packages. Tested the problem by launching
    roslaunch velodyne_description example.launch
    rostopic echo /velodyne_points shows just the warning about the clock and no data.

  5. Kevin Hallenbeck

    I have been unable to reproduce these reports of everything running but not publishing. I tried again today on a virtual machine with Ubuntu 18.04 and only 1 CPU. It took almost 30 seconds to startup, but it published PointCloud2 messages correctly.

  6. Maxim Rovbo

    Full install of all velodyne packages resolved the problem:

    sudo apt install ros-melodic-velodyne*

    Not sure what was missing before since I did not notice any errors or warnings. Sorry for the trouble.

  7. Engineer

    Dear Maxim,

    Thank you so much for your reply. Now it's working fine. We will contact you later, if we need any further help from you. Thanks once again.

    Best regards, Zohaib

  8. Francisco Yandun

    In my case there was a missing library ( I figured out that enabling the verbose option in the launch file. What I did was get it with sudo apt-get install -y libzzip-dev. Then went to /usr/lib/x86_64-linux-gnu and copied to …./catkin_ws/devel/lib and remane it to After that everything worked well.

    I think it is a problem with the graphics engine (OGRE) of some versions of Gazebo. Mine is 7.16.0.

  9. Log in to comment