Blender 2.93 - Setup menu does not open

Issue #392 resolved
goodwillsoft created an issue

Blender 2.93 -

Setup menu does not open

Advanced menu and Tools menu work as expected. Older versions of Diffeomorphic worked flawlessly on 2.93. Only the last few days thsi bug happened….

Comments (16)

  1. Xin

    2.93 is in Alpha, not even Beta. Wait until it’s released. It would make no sense to try to support an unstable version. Other than that, check the console output to see if there are any errors.

  2. goodwillsoft reporter

    Forgot to say, older versions of Diffeomorphic worked flawlessly on 2.93. Only the last few days thsi bug happened….

  3. Thomas Larsson repo owner

    I don’t see any problems with B2.92 RC. I cannot start B2.92 alpha because some dll is missing.

    Edit: It’s B2.93 that I cannot start.

  4. Luke Graybill

    Same thing here in 2.93 alpha. Just chiming in to note that this is not a change in Diffeomorphic, as I haven’t updated the addon for a while and it broke at some point during the alpha cycle. I am wondering if it has anything to do with Blender now using Python 3.9 instead of 3.7.

    Also, I think there is still value in reporting issues like this, even if 2.93 is in alpha still. Having incompatibilities on the radar (and maybe even fixed) long before the final release of Blender updates is good practice, IMO. (Not to mention, 2.93 is significantly nicer in a few areas, so I’d much rather use it when possible!)

  5. Noname

    For anyone that wants use 2.93 temporary workaround for this issue is:

    • locate and open (i.e. in npp) C:\Users\[userName]\AppData\Roaming\Blender Foundation\Blender\2.93\scripts\addons\Diffeomorphic-import-daz-dev\
    • comment out or remove line 57: addon_updater_ops.check_for_update_background()
    • restart or reload scripts

  6. Thomas Larsson repo owner

    I’m thinking about removing the addon updater completely. It is not my code, I don’t understand it, and besides it is licensed under GPL which technically makes it illegal to use it with the BSD license of the Daz Importer.

  7. Thomas Larsson repo owner

    Moved everything related to the addon updater to a separate file, and don't load that file in Blender 2.93. This should fix issue 392.

    → <<cset d1d6becbd280>>

  8. Thomas Larsson repo owner
    • changed status to open

    The latest commit automatically marked this issue as resolved. Need confirmation that this is the case, since I cannot start Blender 2.93 myself.

  9. Alessandro Padovani

    Thomas, as for the menu not showing up, 1.6.0 commit d32fde7 works fine with blender 2.93, while 1.5.1 commit 5e4815b doesn’t work. The workaround by Noname works fine for 1.5.1. May be you could fix 1.5.1 too to make it work with blender 2.93. Then personally I’m using 2.92 until 2.93 gets ready.

    I’d agree for removing the updater since I find it quite unuseful, manual install is just so easy. But I know others like the updater.

  10. Luke Graybill

    Is there any possibility of getting a 1.5.1c release with this bug fix backported to that branch? The 1.5.1b release does not load properly in 2.93, sadly.

    Blender 2.93 is still 2 months away from final release, but it is currently in Bcon2 stage (2.93 release schedule) and supposedly unlikely to have further large breaking changes, so this is probably as good a time as any for a fix for the addon under that version of Blender.

  11. D. Eric Harmon

    I just downloaded blender 2.93 beta, and the importer still does not work. Is there a zip I can download to replace the one with the bug?

  12. Log in to comment