Running steambackupcli from a Windows Task crashes

Issue #12 new
Eric Schewe
created an issue

Trying to setup scheduled tasks to launch/close Steam and then launch SteamBackupCLI.

The scheduled task says it runs and reports back "0xE0434352" as the result.

Checking the Windows Application log I see the following:

Log Name:      Application
Source:        .NET Runtime
Date:          2018-11-10 12:35:01
Event ID:      1026
Task Category: None
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      MYPC.MYDOMAIN
Description:
Application: steamBackupCLI.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.ArgumentOutOfRangeException
   at System.Console.SetWindowSize(Int32, Int32)
   at steamBackupCLI.Program.Main(System.String[])
Log Name:      Application
Source:        Application Error
Date:          2018-11-10 12:35:01
Event ID:      1000
Task Category: (100)
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      MYPC.MYDOMAIN
Description:
Faulting application name: steamBackupCLI.exe, version: 1.8.6.0, time stamp: 0x55a9a286
Faulting module name: KERNELBASE.dll, version: 10.0.14393.2580, time stamp: 0x5bbdace7
Exception code: 0xe0434352
Fault offset: 0x0000000000034048
Faulting process id: 0x1e9c
Faulting application start time: 0x01d47934da703e8b
Faulting application path: C:\Program Files (x86)\Steam Backup Tool\v1_8_6\steamBackupCLI.exe
Faulting module path: C:\Windows\System32\KERNELBASE.dll
Report Id: cf1f75bf-810b-4538-b6c7-0fa49ee951b1
Faulting package full name: 
Faulting package-relative application ID: 

This occurs if running SteamBackupCLI by calling it directly in the scheduled task or via a batch file and the scheduled task.

Here is the command I am running:

"C:\Program Files (x86)\Steam Backup Tool\v1_8_6\steamBackupCLI.exe" -O E:\Steam-Backups -S E:\Steam -2 -C 5 -L -T 2

If I run that manually via PowerShell Prompt or Command Prompt it works just fine.

I also found this in the Application log:

Log Name:      Application
Source:        Windows Error Reporting
Date:          2018-11-10 12:35:02
Event ID:      1001
Task Category: None
Level:         Information
Keywords:      Classic
User:          N/A
Computer:      MYPC.MYDOMAIN
Description:
Fault bucket , type 0
Event Name: CLR20r3
Response: Not available
Cab Id: 0

Problem signature:
P1: steamBackupCLI.exe
P2: 1.8.6.0
P3: 55a9a286
P4: mscorlib
P5: 4.7.3221.0
P6: 5b8858c6
P7: b39
P8: 225
P9: System.ArgumentOutOfRange
P10: 

Attached files:

These files may be available here:
C:\ProgramData\Microsoft\Windows\WER\ReportQueue\AppCrash_steamBackupCLI.e_62dac329fb5c923049c70b1c5f06b20328b82_9ae05958_47229e15

Analysis symbol: 
Rechecking for solution: 0
Report Id: cf1f75bf-810b-4538-b6c7-0fa49ee951b1
Report Status: 96
Hashed bucket: 

The .wer file is attached

Comments (2)

  1. Eric Schewe reporter

    Additional error output that might be helpful when trying to run SteamBackupCLI.exe via PowerShell script

    .\steamBackupCLI.exe -O E:\Steam-Backups -S E:\Steam -2 -C 5 -L -T 2
    .\steamBackupCLI.exe : 
    At line:4 char:1
    + .\steamBackupCLI.exe -O E:\Steam-Backups -S E:\Steam -2 -C 5 -L -T 2  ...
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : NotSpecified: (:String) [], RemoteException
        + FullyQualifiedErrorId : NativeCommandError
    
    Unhandled Exception:
    
    System.IO.IOException: The handle is invalid.
       at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
       at System.Console.GetBufferInfo(Boolean throwOnNoConsole, Boolean& succeeded)
       at System.Console.GetBufferInfo()
       at System.Console.SetWindowSize(Int32 width, Int32 height)
       at steamBackupCLI.Program.Main(String[] args)
    
  2. Eric Schewe reporter

    If I run the scheduled task only when the current user is logged in via this command:

    start powershell ".\steamBackupCLI.exe -O E:\Steam-Backups -S E:\Steam -2 -C 5 -L -T 2"

    Things appear to work fine. The issue seems to be that SteamBackupCLI is expecting some kind of console window to be opened on launch, resized and then dump its output to.

    Can a flag be added so that all output is dumped to a text file instead of the screen? That would likely solve this issue.

  3. Log in to comment