Issue #80 wontfix

mounting shared dirs appears to be failing

Barbara Hill
created an issue

I shared my parent dir "GSDemo" for user "GSDemo" with my bhill user, but I'm not seeing the dir in my bhill ui

IS this covered by this known issue?

"- Mounting shared directories is failing to mount - error looks like CORS is not present on the identity server, I know this work was done, maybe its not yet deployed?"

Comments (9)

  1. Barbara Hill reporter

    update - it seems to work if you mount a URL, but not if you use the share menu from the directory you want to share.

    ie if I want to share GSDemo's parent dir with bhill:

    it works if I copy the url from GSDemo and paste it into the mount shared dir dialog in bhill's gsui

    it does nothing if I go into the Sharing menu in GSDemo's parent dir and try to share it with bhill.

  2. Barbara Hill reporter

    In verifying #81 I tried sharing a file from bhill to GSDemo - it sent the email and when I tried to follow the instructions to mount the file it looked like maybe it had gone through, but now the left hand menu is hung with the wait cursor (Firefox WinXP)

  3. mocana

    Perhaps same problem? igvtest is unable to mount any directories using JSUI. When you try it, there is an error and the whole page is reloaded. It looks like before reloading, it tries to look up the user profile, the server indicates it is not found, then the client tries to POST a profile with the mounted directory, the server returns a blank response.

  4. Ted Liefeld repo owner

    (Reply via lie...@broadinstitute.org):

    I made a change around this code in the last release (the stuff for creating the directory div's). I think I must have introduced a new bug here then but given the Destination Imagination tournament for my kids tomorrow, I won;t be back to looking at this till sunday at the earliest

    Ted

  5. Log in to comment