1. Gfy
  2. pyReScene
  3. Issues
Issue #46 new

Error during reconstruction: "Still not fine :("

Anonymous created an issue

Reconstruction of Castlevania.Lords.of.Shadow.2.Update1.incl.DLC-CODEX fails with the error "Still not fine :(".

This is using http://www.srrdb.com/release/details/Castlevania.Lords.of.Shadow.2.Update1.incl.DLC-CODEX, pyReScene 0.5, Python 2.7:

Z:\Castlevania.Lords.of.Shadow.2.Update1.incl.DLC-CODEX>srr -q Castlevania.Lords.of.Shadow.2.Update1.incl.DLC-CODEX.srr File OK: codex-castlevania.los2.update1.dlc.iso. All files OK!

Z:\Castlevania.Lords.of.Shadow.2.Update1.incl.DLC-CODEX>srr Castlevania.Lords.of.Shadow.2.Update1.incl.DLC-CODEX.srr -z z:\rar -t z:\temp
SRR file created with pyReScene Auto 0.5.
Recreating stored file: codex.nfo
Recreating stored file: codex-castlevania.los2.update1.dlc.sfv
Re-creating RAR file: codex-castlevania.los2.update1.dlc.rar
Trying to rebuild compressed file codex-castlevania.los2.update1.dlc.iso.
Grabbing large enough data piece size for testing.
Trying 2014-06-10 5.10.
Good RAR version detected: 2014-06-10 5.10
z:\rar\2014-06-10_rar510.exe a -m3 -mdG -s- -ds -mt4 -vn -o+ -ep -idcd -vn -v64445223b Z:\temp\tmpasdfoa_pyReScene\pyReScene_compressed.rar Z:\Castlevania.Lords.of.Shadow.2.Update1.incl.DLC-CODEX\codex-castlevania.los2.update1.dlc.iso
Compressing codex-castlevania.los2.update1.dlc.iso...

Evaluation copy. Please register.

Creating archive Z:\temp\tmpasdfoa_pyReScene\pyReScene_compressed.rar

Adding    Z:\Castlevania.Lords.of.Shadow.2.Update1.incl.DLC-CODEX\codex-castlevania.los2.update1.dlc.iso
Calculating the checksum

Creating archive Z:\temp\tmpasdfoa_pyReScene\pyReScene_compressed.r00

...       codex-castlevania.los2.update1.dlc.iso
Calculating the checksum


..etc..


Creating archive Z:\temp\tmpasdfoa_pyReScene\pyReScene_compressed.r86

...       codex-castlevania.los2.update1.dlc.iso                      OK
Calculating the checksum
5637040285
5658044440
Still not fine :(.
Traceback (most recent call last):
  File "Z:\pyReScene\rescene\srr.py", line 460, in main
    parser.exit(manage_srr(options, infolder, infiles, working_dir))
  File "Z:\pyReScene\rescene\srr.py", line 246, in manage_srr
    options.rar_executable_dir, options.temp_dir)
  File "Z:\pyReScene\rescene\main.py", line 1148, in reconstruct
    in_folder, hints, auto_locate_renamed)
  File "Z:\pyReScene\rescene\main.py", line 1496, in get_rar_data_object
    in_folder, hints, auto_locate_renamed))
  File "Z:\pyReScene\rescene\main.py", line 1764, in compressed_rar_file_factory
    nblock, followup_src, solid=False)
  File "Z:\pyReScene\rescene\main.py", line 1959, in __init__
    raise ValueError("Still not fine :(.")
ValueError: Still not fine :(.
Unexpected Error: Still not fine :(.

Comments (3)

  1. Gfy repo owner
    • [16:09:55] <A> sometimes the wrong rar version is detected as working, you could also try some of the rar versions close to the one that failed
    • [16:12:11] <B> what's the command to specify which rar ver to use?
    • [16:13:47] <B> i could just remove the one it worked with from the folder
    • [16:21:29] <A> yes, that works. I had to do that to a lot of old pc releases using rar 3.x
    • [16:26:10] <C> A you had much luck forcing it to work on the cue file of older bin/cue games?
    • [16:26:42] <C> i found that often it will correctly recontruct the rarset until adding the cue then it cant find good rar version
    • [16:44:20] <A> C: sometimes that is fixed by trying another version, sometimes not. For releases from certain groups I found it impossible to get pyene to deterescct the correct version, I guess all the 3.00-3.42 rar versions produce similar output in the beginning when used with certain parameters
    • [16:44:40] <A> so whichever version it found first was then used
    • [16:47:54] <C> yup
    • [16:48:19] <C> i have some old razor releases that it wont do
    • [16:48:41] <C> i'm thinking that grps sometimes use some weird setting
    • [16:49:33] <C> like newer PROPHET releases just always seem to fail for example
    • [16:49:51] <C> just on single iso not even bin/cue
  2. Log in to comment