Cant connect KeePass with DropBox

Create issue
Issue #28 open
Rambo Junior created an issue

Hi,

The next error gonna sounds stupid, so I'm gonna write every details what i have done.

I made a fresh install of KeePass portable version v2.21(http://downloads.sourceforge.net/keepass/KeePass-2.21.zip) I copied over the KPDataSave-0.0.4_for_KeePass-2.21 DLL (https://bitbucket.org/HexRx/kpdatasave/downloads/KPDataSave-0.0.4_for_KeePass-2.21.zip) to the correct location, if I run KeePass and try to login to DropBox it gives an error message : Error executing query. Check your Internet connection!" and here comes the strange part after this error if I renamed KeePass.exe to KeePassPortable.exe (or just KeePassA.exe) it is able to make the connection between KeePass and DropBox.

No windows FireWall is turned on or any other FW software, I disabled my antivirus Sw as well and tried on diffrent PC-s.

Anyone else experience this error?

Thanks in advance!

Regards,

Zoltán Ód

Comments (15)

  1. zhaofa0331

    hello,I have the same problem in liunx mint 14 mate. I have install keepass2 in software manager,then I had copy the plugin to the right dictionary such as /usr/lib/keepass/ , when i run this plugin,the problem is the same. Anyone else experience this error? Thanks in advance!

    zhaofa

    Regards,

  2. Роман Кархачев

    Hello, OpenSuSE 12.3, KeePass 2.24, kpdatasave 0.0.5.0, same problem. On my home PC with Windows 8 plugin work correctly. Can I fill my login information to any parameter file?

  3. Starbeamrainbowlabs -

    I have this same problem on Ubuntu 15.10. Here's my uname -a:

    Linux Snowflake 3.19.0-30-generic #34-Ubuntu SMP Fri Oct 2 22:08:41 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
    

    I started KeePass2 through the terminal, and I got this output, beginning when I started KeePass2:

    SendMessage (77594666, 0x112c, 0x4, 0x4)
    SendMessage (77594660, 0x101f, (nil), (nil))
    SendMessage (0, 0x1203, (nil), 0x7fff5bb70900)
    SendMessage (0, 0x1204, (nil), 0x7fff5bb70900)
    SendMessage (0, 0x1203, 0x1, 0x7fff5bb70900)
    SendMessage (0, 0x1204, 0x1, 0x7fff5bb70900)
    SendMessage (0, 0x1203, 0x2, 0x7fff5bb70900)
    SendMessage (0, 0x1204, 0x2, 0x7fff5bb70900)
    SendMessage (0, 0x1203, 0x3, 0x7fff5bb70900)
    SendMessage (0, 0x1204, 0x3, 0x7fff5bb70900)
    SendMessage (0, 0x1203, 0x4, 0x7fff5bb70900)
    SendMessage (0, 0x1204, 0x4, 0x7fff5bb70900)
    SendMessage (77594660, 0x101f, (nil), (nil))
    SendMessage (0, 0x1203, (nil), 0x7fff5bb71b60)
    SendMessage (0, 0x1204, (nil), 0x7fff5bb71b60)
    SendMessage (0, 0x1203, 0x1, 0x7fff5bb71b60)
    SendMessage (0, 0x1204, 0x1, 0x7fff5bb71b60)
    SendMessage (0, 0x1203, 0x2, 0x7fff5bb71b60)
    SendMessage (0, 0x1204, 0x2, 0x7fff5bb71b60)
    SendMessage (0, 0x1203, 0x3, 0x7fff5bb71b60)
    SendMessage (0, 0x1204, 0x3, 0x7fff5bb71b60)
    SendMessage (0, 0x1203, 0x4, 0x7fff5bb71b60)
    SendMessage (0, 0x1204, 0x4, 0x7fff5bb71b60)
    SendMessage (77594660, 0x101f, (nil), (nil))
    SendMessage (0, 0x1203, (nil), 0x7fff5bb71780)
    SendMessage (0, 0x1204, (nil), 0x7fff5bb71780)
    SendMessage (0, 0x1203, 0x1, 0x7fff5bb71780)
    SendMessage (0, 0x1204, 0x1, 0x7fff5bb71780)
    SendMessage (0, 0x1203, 0x2, 0x7fff5bb71780)
    SendMessage (0, 0x1204, 0x2, 0x7fff5bb71780)
    SendMessage (0, 0x1203, 0x3, 0x7fff5bb71780)
    SendMessage (0, 0x1204, 0x3, 0x7fff5bb71780)
    SendMessage (0, 0x1203, 0x4, 0x7fff5bb71780)
    SendMessage (0, 0x1204, 0x4, 0x7fff5bb71780)
    

    I'm using KeePass 2.28, and the latest version of this plugin.

    If there's any more information you need, I'm more than happy to take a look, given the instructions.

    Here's a picture of the error message that I get:

    Untitled window_001.png

    Here are the steps I took:

    1. Make sure that KeePass and KPDataSave are up to date
    2. Open KeePass
    3. Open the password database
    4. Go to Tools->KPDataSave
    5. Click "Sign In"

    Expected result: It lets me sign in

    Actual result: I get the following error message:

    Error executing query.
    Check your Internet connection!
    
  4. alex51

    I confirm the problem

    Error message: Error executing query. Check your Internet connection!" Why is there no solution to this problem?

  5. Bastien Hug

    Same here. It seems that the developer is no longer active. The plugin is no longer usable on Win10.

  6. ambicrys

    I’ve succeeded to save database to DropBox after applying some steps…

    I’ve downloaded source project from link above (Thanx, Geograph!) and built it to get KPDataSave.dll

    Then Run KeePass v2.41, go to menu Tools/Plugins ->Open Folder-> select compiled KPDataSave.dll from \bin\Debug project folder.

    When I open my database *.kdbx and tried to save it to DropBox I got following error in the status line:

    “Error in call to API function “files/upload” the given OAuth 2 access token is malformed“

    One should update access token.

    If you were already signed in with KPDataSave you should sign out and sign in again through KeePass menu Tools/KPDataSave.

    While signing in you will be redirected to your DropBox account page in browser.

    You should grant access to KPDataSave there and get new access token (it’s just a string without spaces).

    Copy this token to KPDataSave-plugin Form in KeePass App and point desired DropBox location you want to grant access to (All account/Folder/Subfolder).

    Then try to save your Database in KeePass via File/Save.

    KPDataSave should save your local file to DropBox now.

    Good Luck!

  7. Log in to comment