hibp_paste module not working

Issue #216 resolved
CrazianTek
created an issue

Aloha,

I am getting the following error when running this module against the database. It will run the first email then kick off the error:

[!] TypeError: 'NoneType' object is not iterable

Please advise.

Thanks!

Comments (12)

  1. Jon

    Same here on hibp_paste, and breach. It's not following a sequence tho which seems a bit odd. I've got 5740 rows in this DB, all of them have associated email addresses (which I put in via query insert), sometimes it will throw up the "[!] TypeError: 'NoneType' object is not iterable." after the first entry, next time the fifth, etc. Please let me know if I can provide any details to help

  2. Jon

    I'm in no way affiliated with the project, and don't know my ass from a hole in the ground, but I did do a little bit of digging on it. If you look at the rcode that's being returned when it throws the NoneType error, it's getting a 429 back (too many requests, assuming something changed with the data provider?). So I put in a sleep when it got a 429 back to test and it's running now without failing. Again, I don't have anything to do with the project and I'm 100% sure Tim will have a real fix, but that's what I'm seeing.

  3. Shane

    I fixed it like Jon did above. Edit the hibp_breach module (probably same fix for the paste module) and at the top place a line that says: "import time" then right before the continue line enter the following: elif rcode == 429: time.sleep(3) (this is under the 429 line. Just follow the formatting in the module..)

    save the file and then open recon-ng run the reload command. That fixed it for me. Thank you Jon and Michael Lubinski! I'm sure it will be fixed by Tim soon.

  4. Tim Tomes repo owner

    Fixed a bug in the hashes_org module.

    Fixed a bug in the fullcontact module.

    Fixed a bug in the search mixin. Resolves issue #178. (@Mark Muir)

    Added the certificate_transparency module. (@Rich Warren)

    Updated the hibp modules to account for rate limiting changes. Resolves issue #216.

    Fixed a bug in the recon-rpc script. (@Inspector Cat)

    Updated the ssl_san module to leverage the ssltools API. (@Bryan Onel)

    Fixed a bug in the whois_miner module.

    Modified the output that occurs when adding ports to the database.

    Updated the censysio module to handle pagination. (@John Askew)

    Split the twitter module into the twitter_mentions and twitter mentioned modules, added rate limiting to the search_twitter_api method, and configured both modules to store results in the database.

    → <<cset 63acef781344>>

  5. Log in to comment