Do you have any objections to making the "domains" option have only 2 possibilities: a path to a file (with the default value being the path to the included "domains-scrape.lst" file) and a single host? I think we could drop the logic which allows for the user to set a "default" value for the option, seeing as the default value with be the same path.
Also, I'd like to change the name to cache_snoop. I think more people will be able to relate to the terminology. What makes this module powerful are the domain lists used with it. We will include the AV update domains below, but should probably rename it "av_domains.lst".