problem with typescript 0.9

Issue #11 resolved
Anonymous created an issue

typescript 0.9 need "declare" keyword before "module"

module myNamespace {
      interface myInterface {
             ... some properties
      }
}

In typescript 0.9 this gives the following error.

Error 'declare' modifier required for top level element. 1 TypeLite.d.ts

The generated file should look like

declare module myNamespace {
      interface myInterface {
             ... some properties
      }
}

Comments (3)

  1. Log in to comment