Issue #51 invalid

INSERT & UPDATE don't work after upgrading to 1.6.1

Carlos Perez
created an issue

We had a Django 1.5.5 machine working with the 1.3.1 mssql connector with no problems (1.3.1 since when trying 1.4.2rc2 we had a problem with the datetimes in django's log table).

After upgrading Django to 1.6.1, we are unable to create or modify objects via Django's ORM. The most curious thing is that I will create an object and the index autoincrements, but the row is not created (or is created and deleted silently). UPDATE has no effect. DELETE I haven't tried yet. SELECT works fine.

I've tried 1.4.2rc and 1.5a, but they made no difference (with 1.5a at least the datetime problem is not there anymore).

Windows machine, Python 2.7, SQLServer is 2008 (I believe, I'm not sure right now) in a different machine.

If I downgrade Django to 1.5.5 everything starts working again, so I'm not sure if this is really your problem or Django's. Tomorrow I'll try Django 1.6 and see what happens.

Any suggestion I could try to find out what's wrong?.

Thank you!.

Comments (7)

  1. Michael Manfre repo owner

    Django-mssql 1.5 will be the first version that supports Django 1.6, when it's released. It is currently passes all but 2 tests from the django test suite. Both failing tests are related to a specific aggregate query involving dates. I don't recommend using an alpha version in production.

    Django-mssql 1.4 (final) should work with Django 1.5.5 without issue and passes most of the django test suite, except for a few tests that are poorly written. That's the current setup for my primary site.

    What are the actual database errors you are seeing?

  2. Carlos Perez reporter

    Hi, Michael!.

    Sorry, I misread somewhere then, I thought that the last stable already supported Django 1.6. Any ETA for a definitive version?.

    I'll try and get the DBA to fish the log for errors tomorrow at work and see if we can find anything.

    Thank you for your help and for your work.

  3. Carlos Perez reporter

    Ok, nothing wrong in the error log.

    Is there any kind of verbose setting I can use to generate a log?. Any way I can help to locate this?.


  4. Carlos Perez reporter

    Well, it looks like the problem lies in something that changed in Django 1.6.1. If I downgrade to Django 1.6, INSERTs and UPDATEs start working again with 1.5a. 1.4 won't work, though.

  5. Michael Manfre repo owner

    I'm not sure what would have changed in Django 1.6.1 that would have broken things. Write a minimal test and then use git bisect between 1.6 and 1.6.1 to figure out which commit introduced the problem. If you can figure that out, post the test and the Django commit that introduces the problem.

  6. Log in to comment