Issue #68 resolved
Karthik T created an issue

Is lua socket currently supported? https://bitbucket.org/MartinFelis/love-android-sdl2/issue/54/camera-and-other-hardware-data-inputs implies that it is, but when I run the below code on my android device, it appears to behave like a no-op, while it works correctly on my OSX machine.

 result, statuscode, content = http.request("http://requestb.in/p2jdc1p2")

Comments (7)

  1. Karthik T reporter

    This has bitten me before.. multiple times sadly :P But this project is one of those times. I currently download the game from my server and run it, so INTERNET is enabled and working from the host side.

    Is the syntax right? I noticed that, when registering functions from C for lua, i registered one name and called another, and even that seemed to act like a no-op (register call_android but call call). Just want to make sure im not making any silly mistake like that

  2. Karthik T reporter

    Damn.. weird issue.. It worked once, but after that again no-op.. http://requestb.in/p2jdc1p2?inspect#1djeev This request was made from the phone.. but other attempts after that do not appear.. could it be the result of some caching? I am getting 200 now in the device even if the request is not appearing on the bin..

  3. Karthik T reporter

    looks like their anchor tags are not working.. I mean the request with id b82d8ec1-56d6-42ff-ac46-2ca4076e3278

  4. Karthik T reporter

    Looks like caching of GET requests was the culprit.. I noticed that lately even my PC was not showing up, and that led me to try a POST request http.request("http://requestb.in/p2jdc1p2", "test") which works reliably. Wonder if this is requestb.in fault or otherwise.. Any ideas?

  5. Log in to comment