Jannis Leidel  committed f7b070b

Added an exception about the need to have at least Boto 2.4.

  • Participants
  • Parent commits 6408c5d
  • Branches default

Comments (0)

Files changed (1)

File storages/backends/

 from django.utils.encoding import force_unicode, smart_str
+    from boto import __version__ as boto_version
     from boto.s3.connection import S3Connection, SubdomainCallingFormat
     from boto.exception import S3ResponseError
     from boto.s3.key import Key as S3Key
     raise ImproperlyConfigured("Could not load Boto's S3 bindings.\n"
+boto_version_info = tuple([int(i) for i in boto_version.split('.')])
+if boto_version_info[:2] < (2, 4):
+    raise ImproperlyConfigured("The installed Boto library must be 2.4 or "
+                               "higher.\nSee")
 def setting(name, default=None):