Can't enter the Cave of Steam

Issue #463 new
Former user created an issue

So I just beat the second Augur, and watched the little scene that played out afterwards. However, when I tried to enter the Cave of Steam, it was blocked by a character who said 'Scram kid, you're not allowed in here. The Sky Cult is busy with Helios City right now'.

I tried refreshing the map, and exiting and re-entering the area, but nothing happened.

Then I climbed back to the top of the Jade Tower, and was trapped by Damian who wouldn't let me leave the area until I had beaten the Augur. However, when I went back on the roof, the Augur wasn't there (not too surprising as I had just beaten him), and I was stuck up on the roof.

It seems as though the game hasn't acknowledged me beating the Augur.

Comments (2)

  1. DeadlyShoc

    So you mean to tell me this bug was reported over a year ago and not a single mod has even responded? what in all the unholy fucks in fucking fuck town is this fucking shit?! that means this bug is a whole year old and nobody has even acknowledged it. well fuck me for liking this game I guess.

  2. Log in to comment