cant connect & unable open app.db

Create issue
Issue #8 new
Former user created an issue

I can't download theme with the app, why ? So I download with my pc & transfer that file to folder custom theme then tadaa unable to open dB.file. unsafe homebrew yes it checked

Comments (13)

  1. Red Squirrel repo owner

    Hello, from what you say it seems that the app can not correctly access to the various partitions, are you sure you have enabled the option for "unsafe homebrews"? Did you reboot your PSVita after enabling it? And did you use any tool that redirects the partitions (eg to use uma0 as ux0 or to autoload the microSD adapter)? Do you have some third party plugins enabled? Do you use henkaku or enso? Did you already try to delete and reinstall the app?

    In short you have to give me some additional information because it's hard to help you in any way with what you said me, sorry ^^''

  2. Whyjustmyvita

    After checked unsfase homebrew yes I reboot my Vita. Reinstall app ? Yes i do & reboot my Vita too I don't use micro SD. Henkaku ? Yes I have & play with 3.60 firmware

  3. Red Squirrel repo owner

    Please try to disable it (and reboot the console), because CTM stores its config files (and downloads files) indeed in savedata0: partition, therefore a plugin that messes up that partition could be the issue. However it can not explain why the app can not access the ur0 partition (to the app.db file), but, just to be sure, an attempt should be made.

    Did you have installed any Custom Theme in the past or you're trying to install the first ever? And your console is a PSVita or a PSTV?

  4. Whyjustmyvita

    My console is Vita, yeah this is first time. Then I followed the instruction & Delete my plugin then still not work

  5. Red Squirrel repo owner

    When you go into the Uninstallation function do you get the same error (unable to open the app.db file)?

  6. Whyjustmyvita

    In my memory card the app's cache takes 0b with 0 folder & 0 files There is no backup available for the app.db file

  7. Red Squirrel repo owner

    So it really can't write/read any from the partition. That's very weird, it's the first time that nothing of what I suggested you solves the issue. I really don't know what else you might do at this point. The last thing I can think is: with a file manager (like Vitashell) can you access the partitions? You can view the app.db file from ur0:shell/db/app.db?

  8. Log in to comment