Commits

Roger Haase committed e02cf4c Merge

merge

  • Participants
  • Parent commits e1cf797, d47f266

Comments (0)

Files changed (3)

File MoinMoin/items/ticket.py

         super(TicketUpdateForm, self)._load(item)
         self['submit'].properties['labels'] = {
             'update': L_('Update ticket'),
-            'update_negate_status':
-                L_('Update & reopen ticket') if item.meta.get('closed') else
-                L_('Update & close ticket')
+            'update_negate_status': (L_('Update & reopen ticket') if item.meta.get('closed')
+                                     else L_('Update & close ticket'))
         }
 
     def _dump(self, item):

File MoinMoin/storage/middleware/protecting.py

 from MoinMoin import log
 logging = log.getLogger(__name__)
 
-from whoosh.util import lru_cache
+from whoosh.util.cache import lru_cache
 
 from MoinMoin.constants.rights import (CREATE, READ, PUBREAD, WRITE, DESTROY, ACL_RIGHTS_CONTENTS)
 from MoinMoin.constants.keys import ALL_REVS, LATEST_REVS, NAME_EXACT, ITEMID
     zip_safe=False,
     dependency_links=[
         # 'https://github.com/mitsuhiko/werkzeug/tarball/master#egg=Werkzeug-0.7dev',
-        'https://bitbucket.org/thomaswaldmann/whoosh/get/2.4x.tar.gz#egg=Whoosh-2.4.99dev',
+        # 'https://bitbucket.org/thomaswaldmann/whoosh/get/2.4x.tar.gz#egg=Whoosh-2.4.99dev',
+        'https://bitbucket.org/thomaswaldmann/whoosh/get/default.tar.gz#egg=Whoosh-2.5.99dev',
         # fixed flask-themes, 0.1.3 does not work for flask 0.8.x, thus we use a faked 0.1.3.1:
         'https://bitbucket.org/thomaswaldmann/flask-themes/get/24dcc703953f.tar.gz#egg=Flask-Themes-0.1.3.1',
         'https://bitbucket.org/thomaswaldmann/emeraldtree/get/tip.tar.gz#egg=emeraldtree-0.9.2',
                               # likely due to the fixtures changes.
         'pytest-pep8<1.0.3',  # coding style checker
                               # note: pytest-pep8 1.0.3 needs pytest 2.3
-        'whoosh>=2.4.0',  # needed for indexed search
+        # 'whoosh>=2.4.0',  # needed for indexed search
+        'whoosh>=2.5.0',  # needed for indexed search
         'sphinx>=1.1',  # needed to build the docs
         'pdfminer',  # pdf -> text/plain conversion
         'passlib>=1.6.0',  # strong password hashing (1.6 needed for consteq)