Source

py-patches / killpy24

# HG changeset patch
# Parent 8bba910ff5ec676feb87571c3c94a1dff0734906

diff --git a/py/_builtin.py b/py/_builtin.py
--- a/py/_builtin.py
+++ b/py/_builtin.py
@@ -1,20 +1,5 @@
 import sys
 
-try:
-    BaseException = BaseException
-except NameError:
-    BaseException = Exception
-
-try:
-    GeneratorExit = GeneratorExit
-except NameError:
-    class GeneratorExit(Exception):
-        """ This exception is never raised, it is there to make it possible to
-        write code compatible with CPython 2.5 even in lower CPython
-        versions."""
-        pass
-    GeneratorExit.__module__ = 'exceptions'
-
 _sysex = (KeyboardInterrupt, SystemExit, MemoryError, GeneratorExit)
 
 import six
diff --git a/tox.ini b/tox.ini
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
 [tox]
-envlist=py26,py27,py31,py32,py27-xdist,py25,py24
+envlist=py26,py27,py31,py32,py27-xdist,py25
 #indexserver=
 #    default=http://pypi.testrun.org