Failed to contact validation servers when using Idea's auto-proxy settings

Issue #111 wontfix
Petr Švestka created an issue

Hi Scott,

All of a sudden IntelliJ is telling me this: failed_to_contact_license_servers.png

There's no other way but to kill the process. I can't even get to the setting to prove that proxy is still on nor to the IntelliJ's logs.

There should be some way how to keep working (a day?) when the license cannot be validated. It effectively stops my work now.

Button "yes" can't contact the server. Button "no" won't let IntelliJ continue (infinite loop).

Comments (13)

  1. Scott Wells repo owner

    Sorry for this, Petr. I'll definitely see if there's a more graceful and forgiving way to handle this situation. Two questions for you: 1) do you know of any reason that it wouldn't be able to contact the license server from your workstation (understanding that it might of course be an issue on the license server side); 2) are you able to continue your work in the IDE after manually killing and restarting the process?

  2. Scott Wells repo owner

    Petr, assuming that you're not able to continue your work within Illuminated Cloud even after manually restarting the IDE, I'll see if I can get you a test build with a workaround for this while I research and implement a real solution. Let me see what I can put together...

  3. Petr Švestka reporter

    1) No, unless our IT started to block specific addresses. I don't know which addresses the plugin tries to connect to 2) No, the plugin requires to contact the server. I won't let me in.

    So I deleted the directory from under plugins as suggested in FAQ and downloaded the plugin again - so no generally connectivity problem. Upon restart - the same thing - won't connect to the license servers. Also tried to restart the PC - no change. The only way I can get to Idea is to delete the plugin from the disk.

    If that helps, I could email you my phone number so we can chat over phone.

    Thanks for looking into this.

  4. Scott Wells repo owner

    Thanks for following up. Yeah, the license validator, as you can imagine, persists across uninstall/reinstall, etc. Let me just get you a private build that will buy you a bit of time while I figure out what's going on here. Can you remind me if you're configured to use a proxy server or not?

  5. Scott Wells repo owner

    Hmmmm...auto-proxy, eh? There may be something to that. Let me see what I can figure out.

  6. Petr Švestka reporter

    Well, it worked for the plugin until today. This is a standard settings in Idea and I'm able check a working connection to e.g., google.com or download plugins while using an auto-proxy.

    However, when I changed Idea's settings from an auto-proxy to a manual proxy, the plugin started to be able to connect to its license-validation servers. I'm happy now.

    Since it's now only a minor obstacle when moving from work to home (no proxy), I'll downgrade this bug to minor.

  7. Scott Wells repo owner

    Whew! Thanks for the update. Okay, let me take a look at auto-proxy support and see if there's anything special I need to be doing there (apparently there is!). Thanks again!

  8. Tomasz Kawik

    I know that this issue is quite old, but have you found out any solution? I have the same problem despite the fact that proxy setting is set to no proxy.

    EDIT: I think, that the problem was temporary and could be related to our internal network.

  9. Scott Wells repo owner

    Thanks for the update, Tomasz. I've seen this happen with no proxy in two situations: 1) a temporary network glitch as you've suspected; 2) a locked-down corporate network where the outbound call to the license validation servers must be allowed. As for the original question, though, I haven't made any progress on this because the users who have encountered it have been able to work around it by explicitly specifying a proxy when one is required.

  10. Scott Wells repo owner

    Unfortunately despite my best efforts over time, I can't find any way to get the third-party licensing software to work with automatic proxy configuration. When a proxy comes into play, a manual proxy configuration is required.

  11. Log in to comment