IntelliJ gets frozen using APEX editor

Issue #1226 resolved
Martin Satke created an issue

The intellij app has frozen unexpectedly when working on APEX code. This happened a few times in the past but yesterday it happened several times and the time between these fails was sometimes about 5 minutes.

I checked similar logged issues but still, I have no clue. There seems to be no pattern to any my activity... Some crash occurred when I wasn't typing anything I just saw the cursor stop blinking.

When I looked to the idea log there are many lines like that one: agnostic.FrequentEventDetector - Too many events posted. Attaching logs to this issue.

Thanks for help!

Comments (4)

  1. Scott Wells repo owner

    Hi, Martin. Thanks for providing the logs. I'm seeing a few entries like this:

    2019-01-31 13:45:40,573 [91681851]  ERROR - j.psi.stubs.StubTreeLoaderImpl - Outdated stub in index: file://C:/Work/git/predev002/src/classes/DNV_VeracityOrderService.cls indexed at 1548938623922 with document size 88910, doc=DocumentImpl[file://C:/Work/git/predev002/src/classes/DNV_VeracityOrderService.cls], docSaved=false, wasIndexedAlready=true, queried at 1548938623922

    Do you mind rebuilding caches and indices as described here:

    to see if that helps resolve the situation? Please let me know the outcome either way if you don't mind.

  2. Martin Satke reporter

    Hi, Scott thanks for the quick response!

    I forgot to mention that I've tried clearing the cache yesterday when I was looking for some help among already solved issues. Yesterday it doesn't prevent other issues to occur but I'll definitely try to do it now and let's see if it change something. I'll let you know if there is another issue...

  3. Scott Wells repo owner

    Sounds good, Martin. If you do continue to see it after rebuilding caches/indices for IC, I recommend rebuilding them for the entire IDE (File>Invalidate Caches / Restart) to see if perhaps something at a lower level has gotten into weird state. If that doesn't help, please attach the latest logs and I'll see what else might be going on.

  4. Martin Satke reporter

    Hi Scott, I haven't experienced that issue since last time when I rebuild the caches and restart the whole app. So it seems to help me to prevent this issue to happen again. Thanks for your help to resolve it and also thanks for new improvements to your great tool!

  5. Log in to comment