Syntax Highlighting / Auto Formatting apparently breaking IDE

Issue #1333 new
Dennis Grzyb created an issue

I have monitored this issue on my machine for several months, and when it comes up, it’s 100% reproducible. It comes up when I try to edit some specifics about already working and deployed code, code that has already had Syntax Highlighting run over it.

Just now, I tried to change the return type of a method from String to a List of a Wrapper class, but the IDE froze after I wrote “List<“ and the autocompletion added the closing bracket >. And then, when I copypasted the List including type, it again happened when I tried to wrap a for-loop around an SOQL-Query that was originally cast into a List.

Other instances where it came up was when adding an additional brackets for adding an if-clause when there originally was none. There it froze after I typed in the first bracket and tried to add the second bracket to the end of the code snippet that was supposed to be affected.

I don’t know if the Dump helps, I can also add the idea.log if necessary. However, this is becoming increasingly annoying, especially in a complex Org as the one I am working with where this regularly comes up.

Comments (5)

  1. Scott Wells repo owner

    Sorry for the issue, Dennis, and thanks for providing the diagnostic info. Let me take a look and see if I can figure out what's going on.

  2. Scott Wells repo owner

    Hi, Dennis. I'm still looking into this, but I also just release 2.0.6.7 which included a fix for another deadlock that some users were experiencing. It's possible--though not quite likely--that the same changes might have helped here. Do you mind updating to the latest build and trying to reproduce? Assuming it is reproducible, do you mind sending another thread dump/log combo for review based on the latest build? Thanks!

  3. Dennis Grzyb reporter

    Hello Scott. Thanks for the update. I will update my IDE and notify you the second I see it come up again. I shall try to replicate what I did last time (meaning change the return type of a method returning a String), perhaps I’m “lucky”.

  4. Log in to comment