Issue with certain feature-based SObject variants during OST generation

Issue #1346 resolved
Scott Wells repo owner created an issue

This started via an email discussion with a user, but basically it manifests as unresolvable references to some feature-based SObject name variants. The underlying issue is that IC isn't properly understanding that MyObjectName__Feed, `MyObjectName__VersionHistory, and a few others are actually SObjects and not Feed, VersionHistory, etc., in the MyObjectName namespace. IC was already handling several of these feature-based SObject name variants properly, but some were missing.

Comments (14)

  1. Scott Wells reporter

    Here's a test build with the prospective fix. To install just download the attached archive--do not extract it--and use Settings/Preferences>Plugins>Install plugin from disk (under the gear drop-down). Restart as requested. Once the IDE restarts, regenerate the OST and see if things are fixed.

  2. Gustavo Tandeciarz

    Unfortunately, this update doesn’t seem to have solved the problem for me (can’t resolve a custom object __share object). I installed the plugin from disk, restarted IDEA, generated the OST for All SObjects (not everything, just SObjects), let it reindex, and still get the same ‘Cannot resolve symbol’ error. That object is set to private sharing OWD in the org.

  3. Scott Wells reporter

    Thanks for confirming, Gustavo. Let me play with it a bit and see if I can reproduce it. I'll let you know shortly.

  4. Scott Wells reporter

    Gustavo, I just changed the sharing model for one of my SObjects to private, deployed, and regenerated the OST. I can see the corresponding __Share object in the OST, and it works properly for code completion, etc.:


    Am I misinterpreting the issue that you're having? Perhaps I'm trying to reproduce the wrong thing?

  5. Scott Wells reporter

    Fix for original issue delivered in Gustavo, I'll work with you on the one you're seeing either via this issue or a new, dedicated one.

  6. Gustavo Tandeciarz

    Interesting, yeah, that’s pretty much the exact problem I’m having. Let me try reinstalling the plugin and trying again.

  7. Gustavo Tandeciarz

    Installed and I see the Share object in the OST, but still getting unresolved symbol errors. So it might be something specific to my local environment. This Macbook Air is running low on memory 😛

  8. Scott Wells reporter

    I wouldn't think it would be a low memory thing. You'd see OutOfMemoryError and similar, not very specific, consistently-reproducible resolution issues. What's the name of the object that's shared? Perhaps there's something special about that one object's name. Do you see anything else in the OST suspicious around the base name, e.g., a namespace/folder with the same base name?

  9. Gustavo Tandeciarz

    That worked. I had to delete the original OST and generate a full one, then restart the IDE and now I have symbols for the __Share object 🙂

  10. Scott Wells reporter

    Okay, great! Sit tight on that build and the same change will be in the next official build. When prompted to update to, feel free to do so safely.

  11. Log in to comment