'Force Save' context action does not save edited fields

Issue #1434 resolved
John Rogers created an issue
  • create IC project
  • initialize git repo
  • create two files ‘foo.cls’ and ‘bar.cls’ and commit them
  • make changes to foo.cls and bar.cls and press ‘ctrl + s’ both files save successfully
  • edit foo.cls
  • open changed files view in the project window
  • use ctrl + click to select both foo.cls and bar.cls in the project window
  • right click one of the two selected files to open the context window
  • navigate to ‘Illuminated Cloud’ → ‘Force Save’ and click the action
  • Expected results: both foo.cls and bar.cls are deployed
  • Actual results: only bar.cls is deployed

Thanks for the great tool!

Comments (5)

  1. Scott Wells repo owner

    Thanks for filing, John. I'll see if I can reproduce and fix for next week's build. I'll let you know if I have any issue reproducing it.

  2. John Rogers reporter

    Hey Scott, sorry about the delay - I was on vacation. I enabled debug logging, tested again and it worked! I disabled debug logging & tested - still worked. I am both shocked and delighted. This has been annoying me a little for a year, but the workaround was so easy (save & cancel save, THEN select all & save) that I never logged a bug until now. I can’t explain it. I’ll keep the logging on just in case I can come back with something more concrete. Thanks for the great app! Sorry to waste your time.

  3. Scott Wells repo owner

    Glad to hear, John, and honestly not surprising. I've done a LOT of work in this general area. Let me know if you do see that issue recur, or something like it, and I'll investigate.

  4. Log in to comment