How to control tab size for Aura Components?

Issue #1470 closed
Jason Clark created an issue

When editing an Aura Component (.cmp file) the tab size seem stuck at 4; I’d prefer 2. I have set the Tab Size and Indent Size to 2 for Apex Code (Settings → Editor → Code Style → Apex) which works fine. I have the same settings for HTML, XML, and every other language under “Code Style”, but nothing seems to work. I’ve also tried “Use tabs” on and off.

Comments (4)

  1. Scott Wells repo owner

    Jason, if I change the values for the HTML file type from 4 to 2, it does the right thing:

    Config

    Issue_1470_1.png

    Result

    Issue_1470_2.png

    Does that not work for you?

  2. Jason Clark reporter

    It did not (I tried repeatedly), but after seeing your confirmation that it should work, I restarted Intelli-J and tried again; this time it worked. Thanks, good to close.

  3. Scott Wells repo owner

    Very strange that a restart was required for you. If you (or others) see that behavior again, let me know and I'll raise it with JetBrains.

  4. Log in to comment