Can not get metadata from Salesforce

Issue #154 resolved
Former user created an issue


I have created project with files and all metadata which i need. But when I am trying to get new version of specified metadata from the Salesforce, it does not work.

How to reproduce: 1. Right click on the package 2. Select Illuminated Cloud -> Retrive Metadata... 3. Select some categories 4. Click OK 5. Then is show the "Comparing" window.

Error: In the comparing window is no new version of metadata (classes etc). And when I tried to look in the Temp dir where should be the file with these new metadata, this file is empty (it has 0bytes in size). I am not getting any error with connection problem.


Comments (4)

  1. Scott Wells repo owner

    Have you selected metadata in the module? Deploy and retrieve are "filtered" by the module-level selection. I helped another user debug this last week and the issue was that things weren't selected for the module and therefore weren't retrieved. Think of the module selection as your stable working set and the deploy/retrieve selection as what you want to act upon in that operation as a subset of your stable working set.

    If you have selected a working set for the module and it's still not retrieving, please let me know and we'll debug it more.

  2. Scott Wells repo owner

    Not sure if you're still having this issue, but if you are, you can turn on additional debug logging for the metadata retrieval by going into Help>Configure Debug Log Settings... and adding the following entry:


    Then when you retrieve, a considerable amount of diagnostic info will be written to idea.log (available via Help>Show Log in Explorer/Finder).

  3. Scott Wells repo owner

    Moving this to resolved for now. If the problem is still occurring please feel free to reopen with additional details.

  4. Log in to comment