IDE crashes due to flood of "Failed to obtain the org list from Salesforce DX CLI" errors

Issue #1621 duplicate
Maarten Lapere created an issue

Recently updated both IntelliJ and Illuminated Cloud, and now when I open my IC project the event log gets flooded with the same error:

"Failed to obtain the org list from Salesforce DX CLI"

status = 1

message = Unexpected end of JSON input

After seeing this I also updated the Salesforce DX CLI, but the errors still appear.

This behavior is blocking me from doing any work on this project, a workaround would be appreciated.

Comments (6)

  1. Maarten Lapere reporter

    Just noticed that I get the same error when running

    sfdx force:org:list

    Resulting in:

    ERROR running force:org:list:  Unexpected end of JSON input

    So it seems not to be an Illuminated Cloud issue.

  2. Scott Wells repo owner

    Hi, Maarten. Yes, there are some significant issues with the current build of the Salesforce CLI. I recommend that you temporarily roll back to the last known good version using:

    sfdx plugins:install salesforcedx@48.10.1

    and then keep an eye on issue #1606 for updates on when Salesforce has resolved the underlying problems and it's safe to get back on the latest.

  3. Log in to comment