Support Find Usages for custom VF components/attributes

Issue #197 resolved
Paolo Cosentino created an issue

I clearly remember these features were working correctly, so it got broken in any recent update.

Visualforce Components (like <c:MyComponent />) are no longer being detected by the Offline Symbol Tables.
This is happening for Custom VF Components only (the standard components, such as apex:pageBlock, etc, seem to be working correctly)
The custom components are always displayed in red color (as if it was mistyped) in all pages.

  • Right click in the component and -> Find All References, no longer works
  • Right click in the component and -> "Go to Definition", no longer works
  • Component's parameters auto-completion is no longer displayed while writing it on a page
  • Ctrl + Q (to open component's help), no longer works

Scott: this is an awesome IDE, thank you very much for working on it!

Comments (8)

  1. Scott Wells repo owner

    Thanks for reporting the issue, Paolo. I'm not aware of any changes I've made that would have affected this, but obviously you're seeing it! Let me try to reproduce and I'll let you know what I find.

  2. Scott Wells repo owner

    Paolo, I just tried to reproduce this and am unable to do least not entirely. Of the items you listed, everything works for me except for Find Usages, and I actually don't think I ever implemented that for custom components and their attributes (I should!). It might have worked as a side-effect of reference navigation (Go To Definition), but I never added explicit support. However, I'm seeing Go To Definition, completion, and quick doc (CTRL+Q) working for both custom components and their attributes.

    Since you're not seeing the same thing, let's gather some diagnostic info. Would you mind looking in your idea.log (Help>Show Log in Explorer/Finder) for any errors or stack traces that might be related to this? Also, let's totally rebuild all caches for IntelliJ/Illuminated Cloud using File>Invalidate Caches/Restart with the Invalidate and Restart option.

    Let me know if the latter doesn't help, and any related info from the log will prove invaluable. Also, a simple standalone reproducible test case would be great. That way I can see if I'm able to reproduce it using an exact component that shows the problems for you. Hopefully you can create a VERY simple component and page that references that component.

    Thanks much!

  3. Paolo Cosentino reporter

    Thanks Scott for the quick reply.
    Successfully! the "Invalidate Cache .." worked great!
    Now Ctrl+Q, "Go to Definition" and "parameters suggestion while typing", are worked perfectly again!

    The only issue that remains is (like you said) the "Find Usages" is not returning any references in the result, but I guess is not big thing so I will leave this bug reported with "Minor" priority if you think so.

    Thanks again.

  4. Scott Wells repo owner
    • edited description
    • changed status to resolved

    I'm unable to reproduce this. I was opened quite a bit back and I've worked heavily on enhancements to the way references are injected/tracked for custom components and their attributes. Please let me know if you're still seeing this issue.

  5. Log in to comment