Deployment not reporting reason why it failed on for-loop.

Issue #296 wontfix
Robert Conner created an issue

I had this bad for-loop in an apex class. When deploying, the status was FAILED. However there was nothing in the editor to indicate which line of code had the failure. Additionally the little green checkbox in the top right corner was still there instead of the expected red circle.

for(Integer i=0 ; i++ ; i<4) {

Comments (5)

  1. Scott Wells repo owner

    Thanks for the concrete example, Robert. I'll look into this and hopefully get it resolved in a short-term update.

  2. Scott Wells repo owner

    Robert, I tried to reproduce this issue today and wasn't able to do so. I'm getting the proper behavior:


    I tried with both the Tooling API (default) and Metadata API for deployment, both with the same results.

    Obviously this is happening to you, so if you don't mind I'll need you to provide some additional diagnostic info. Would you mind adding the following under Help>Debug Log Settings:


    Then deploy the cited code, verify that you didn't get an error, and provide the relevant extract from idea.log for my review. Thanks!

  3. Log in to comment