INVALID_TYPE: sObject type 'ApexClassIdentifier' is not supported.

Issue #462 resolved
Dion Gunn created an issue

Hello there,

I've unfortunately encountered an error when trying to create a new project. I've tried uninstalling the plugin and IntelliJ but still run into the same issue :(

I receive the error "INVALID_TYPE: sObject type 'ApexClassIdentifier' is not supported." when it looks like it's generating the class overlay/symbol table.

I've attached the log. This is with IlluminatedCloud 1.7.5.4-idea14 and IDEA 2016.2.5 (BUILD: IC-162.2228.15)

Thanks for your help.

Cheers,

Dion

Comments (5)

  1. Dion Gunn reporter

    OK, I've tried this with a few more orgs and I think I've found the issue. The orgs that generate this error appear to be in Trial, so is most likely the cause of the issue and not with IC. I think this can be closed, but I'll leave it open for you in case you still wanted to review the log. :).

  2. Scott Wells repo owner

    Thanks for researching, Dion. That helps quite a bit. I'll follow up with Salesforce to understand why Trial orgs don't have access to that info. If you do want to use IC against those orgs, you can uncheck Apply Class Overlays in the connection and it won't query that info when generating the OST.

  3. Scott Wells repo owner
    • changed status to resolved
    • edited description

    Since this is only against trial orgs and you can avoid the issue by configuring connections to those orgs not to apply class overlays, I'm resolving this one.

  4. Log in to comment