Cannot set metadata subscription to "package.xml" in Module Settings under Mac OS X

Issue #850 new
Fabio Andree Scheurel created an issue

Whenever I select a package.xml in the Module Settings to set my metadata subscription to a manually predefined subscription, after confirming the open file dialog the file has not been selected (see "Screen Shot 2018-01-09 at 16.02.44.png").

If I confirm the dialog, Illuminated Cloud will complain about a misconfiguration, see "Screen Shot 2018-01-09 at 16.01.51.png".

I did not find any way on how to set the subscription model to my package.xml. As a workaround I manually selected the components I want to retrieve or sync.

This issue only occurs under Mac OS X High Sierra 10.13.2 and is reproducible on other computers with Mac OS. Another computer with Windows 10 does not show this issue.

idea.log does not list any entry during configuration edit.

Comments (8)

  1. Scott Wells repo owner

    Fabio, where is your package.xml file? Is it under the project's source root? IC requires it to be within the project's source locations. Since this happens on Mac but not Windows, I fear that's not likely the case, but I figured I'd check for the easy solution before diving into other options. If that doesn't help, though, please send me your idea.log using Help>Show Log in Finder.

  2. Fabio Andree Scheurel reporter

    Hey Scott, I tried several solutions, by putting the file into the project root, into the src folder or at a complete different location on my hard drive. In any case, the result was the same. Regarding the idea.log there are no log entries within the timeframe in which I was playing around with the configuration, so unfortunately I cannot send you any helpful information.

  3. Scott Wells repo owner

    Sorry for the delayed response...BitBucket was having some issues. So when the dialog in the first screenshot opens and you choose the Package.xml radio button, do you then click the ... browse button beside the text field and select your package.xml file? If not, please do so as you need to tell IC where your package.xml file is. If so, is that value discarded after you close that dialog and reopen it?

  4. Fabio Andree Scheurel reporter

    Dear Scott, I do click on the browse button, and after I selected my package.xml within the popup dialog, the value is discarded. The selection from the popup dialog is never ever applied. After closing the configuration dialog and reopening it, still no package.xml is selected. In other words, the configuration dialog as shown in Screen Shot 2018-01-09 at 16.02.44.png always looks exactly like this.

    From a programmer's perspective, I'd say that something fails internally when parsing the returned file path from the system's browse dialog on OS X systems.

  5. Scott Wells repo owner

    Gotcha, and sorry to be repetitive, but in my experience the only time this happens is when the selected package.xml isn't under a source root. Can you send me a screenshot of your module configuration under File>Project Structure>Modules>yourModuleName>Sources as well as the path to your package.xml file? I just want to make sure that things line up properly.

  6. Scott Wells repo owner

    Thanks. Yep, that's all as I'd expect it to be. Let me take a look and see if I can reproduce it on my Mac. Worst-case scenario I may need to either get on a screenshare with you so we can try a few things interactively, or I may need to send you a build with more debug logging so that I can observe it via the log. I'll let you know. Sorry for the issue and thanks for all the diagnostic info!

  7. Scott Wells repo owner

    One more question...after you select that package.xml file, do you see the text field beside Package.xml populated with src/package.xml? I just tried to reproduce this on my Mac and it didn't reproduce, but I wanted to know it's failing to get a relative path for the selected file or when applying that configuration change.

  8. Log in to comment