Commits

M0E-lnx  committed 6802d7c

lxsession update to 0.4.9.2 and add support for clipboard and polkit

  • Participants
  • Parent commits 4f84d55

Comments (0)

Files changed (1)

File var/vabs/lxsession/src/lxsession.SlackBuild

 # AUTHORS = 
 
 NAME="lxsession"            #Enter package Name!
-VERSION=${VERSION:-"0.4.6.1"}      #Enter package Version!
+VERSION=${VERSION:-"0.4.9.2"}      #Enter package Version!
+BASEVER=$(echo $VERSION |cut -f 1-3 -d .)
 VER=$(echo $VERSION|sed 's/-/_/') #this fixes - in version
 VL_PACKAGER=${VL_PACKAGER:-"hata_ph"}   #Enter your Name!
-LINK=${LINK:-"http://downloads.sourceforge.net/project/lxde/LXSession%20%28session%20manager%29/LXSession%20${VERSION}/${NAME}-${VERSION}.tar.gz"}  #Enter URL for package here!
-
+LINK=${LINK-"http://downloads.sourceforge.net/project/lxde/LXSession%20%28session%20manager%29/LXSession%20${BASEVER}/lxsession-0.4.9.2.tar.gz"}
 
 #SYSTEM VARIABLES
 #----------------------------------------------------------------------------
-BUILDNUM=${BUILDNUM:-"2"}
+BUILDNUM=${BUILDNUM:-"1"}
 VL_VERSION=${VL_VERSION:-"$(ls /var/log/packages/|grep vlconfig2|cut -d "-" -f4|cut -c 2-5)"}
 BUILD=${BUILD:-"$BUILDNUM""$VL_VERSION"}
 ARCH=${ARCH:-"$(uname -m)"}
 LDFLAG_OPTIONS=${LDFLAG_OPTIONS:-""}
 ADDRB=${ADDRB:-""} #Add deps that need to be added to the slack-required file here
 EXRB=${EXRB:-""} #Add deps that need to be excluded from the slack-required file here
-MAKEDEPENDS=${MAKEDEPENDS:-"ConsoleKit harfbuzz"}
+MAKEDEPENDS=${MAKEDEPENDS:-"ConsoleKit harfbuzz dbus-glib libgee vala icu4c graphite2"}
 #----------------------------------------------------------------------------
 
 if [ "$NORUN" != 1 ]; then
   --infodir=/usr/info \
   --sysconfdir=/etc \
   --localstatedir=/var \
+  --enable-buildin-polkit \
+  --enable-buildin-clipboard \
+  --enable-dbus \
   --mandir=/usr/man \
   --program-prefix="" \
   --program-suffix="" \