Commits

stretchedthin committed 8871ca5

ibus dependent builds

  • Participants
  • Parent commits 750969a

Comments (0)

Files changed (7)

var/vabs/ibus-anthy/src/ibus-anthy.SlackBuild

 # AUTHORS = 
 
 NAME="ibus-anthy"            #Enter package Name!
-VERSION=${VERSION:-"1.2.6"}      #Enter package Version!
+VERSION=${VERSION:-"1.2.7"}      #Enter package Version!
 VER=$(echo $VERSION|sed 's/-/_/') #this fixes - in version
 VL_PACKAGER=${VL_PACKAGER:-"hata_ph"}   #Enter your Name!
-LINK=${LINK:-""}  #Enter URL for package here!
+LINK=${LINK:-"https://ibus.googlecode.com/files/ibus-anthy-1.2.7.tar.gz"}  #Enter URL for package here!
 
 
 #SYSTEM VARIABLES
 LDFLAG_OPTIONS=${LDFLAG_OPTIONS:-""}
 ADDRB=${ADDRB:-""} #Add deps that need to be added to the slack-required file here
 EXRB=${EXRB:-""} #Add deps that need to be excluded from the slack-required file here
+MAKEDEPENDS=${MAKEDEPENDS:-"ibus"}
 #----------------------------------------------------------------------------
 
 

var/vabs/ibus-chewing/src/ibus-chewing.SlackBuild

 # AUTHORS = 
 
 NAME="ibus-chewing"            #Enter package Name!
-VERSION=${VERSION:-"1.3.9.2"}      #Enter package Version!
+VERSION=${VERSION:-"1.3.10"}      #Enter package Version!
 VER=$(echo $VERSION|sed 's/-/_/') #this fixes - in version
 VL_PACKAGER=${VL_PACKAGER:-"hata_ph"}   #Enter your Name!
-LINK=${LINK:-""}  #Enter URL for package here!
+LINK=${LINK:-"http://ibus.googlecode.com/files/ibus-chewing-1.3.10-Source.tar.gz"}  #Enter URL for package here!
 
 
 #SYSTEM VARIABLES
 LDFLAG_OPTIONS=${LDFLAG_OPTIONS:-""}
 ADDRB=${ADDRB:-""} #Add deps that need to be added to the slack-required file here
 EXRB=${EXRB:-""} #Add deps that need to be excluded from the slack-required file here
+MAKEDEPENDS=${MAKEDEPENDS:-"ibus gob2 libchewing"}
 #----------------------------------------------------------------------------
 
 
 PKG=$TMP/package-$NAME
 #--------------------------------------------
 
-
+wget https://fedorahosted.org/releases/c/m/cmake-fedora/cmake-fedora-0.8.1-modules-only.tar.gz
 
 if [ $UID != 0 ]; then
    echo "You are not authorized to run this script. Please login as root"
 
 
 cd $TMP/$NAME-$VERSION-Source
-
+tar xvf $CWD/cmake-fedora-0.8.1-modules-only.tar.gz
 # Put any Patches into a patches folder in the src dir
 #-----------------------------------------------------
 #for i in $CWD/patches/*;do
 
 echo "Configuring source..."
 cmake \
+    -DCMAKE_C_FLAGS_RELEASE:STRING="$SLKCFLAGS" \
+    -DCMAKE_CXX_FLAGS_RELEASE:STRING="$SLKCFLAGS" \
     -DCMAKE_INSTALL_PREFIX=/usr \
     -DSYSCONF_INSTALL_DIR=/etc \
     -DDOC_DIR=/usr/doc \

var/vabs/ibus-hangul/src/ibus-hangul.SlackBuild

 VERSION=${VERSION:-"1.3.1"}      #Enter package Version!
 VER=$(echo $VERSION|sed 's/-/_/') #this fixes - in version
 VL_PACKAGER=${VL_PACKAGER:-"hata_ph"}   #Enter your Name!
-LINK=${LINK:-""}  #Enter URL for package here!
+LINK=${LINK:-"http://ibus.googlecode.com/files/ibus-hangul-1.3.1.tar.gz"}  #Enter URL for package here!
 
 
 #SYSTEM VARIABLES
 LDFLAG_OPTIONS=${LDFLAG_OPTIONS:-""}
 ADDRB=${ADDRB:-""} #Add deps that need to be added to the slack-required file here
 EXRB=${EXRB:-""} #Add deps that need to be excluded from the slack-required file here
+MAKEDEPENDS=${MAKEDEPENDS:-"ibus"}
 #----------------------------------------------------------------------------
 
 

var/vabs/ibus-pinyin/src/ibus-pinyin.SlackBuild

 VERSION=${VERSION:-"1.3.11"}      #Enter package Version!
 VER=$(echo $VERSION|sed 's/-/_/') #this fixes - in version
 VL_PACKAGER=${VL_PACKAGER:-"hata_ph"}   #Enter your Name!
-LINK=${LINK:-""}  #Enter URL for package here!
+LINK=${LINK:-"http://ibus.googlecode.com/files/ibus-pinyin-1.3.11.tar.gz"}  #Enter URL for package here!
 
 
 #SYSTEM VARIABLES
 LDFLAG_OPTIONS=${LDFLAG_OPTIONS:-""}
 ADDRB=${ADDRB:-""} #Add deps that need to be added to the slack-required file here
 EXRB=${EXRB:-""} #Add deps that need to be excluded from the slack-required file here
+MAKEDEPENDS=${MAKEDEPENDS:-"ibus"}
 #----------------------------------------------------------------------------
 
 
 PKG=$TMP/package-$NAME
 #--------------------------------------------
 
+wget http://ibus.googlecode.com/files/pinyin-database-1.2.99.tar.bz2
 
 
 if [ $UID != 0 ]; then

var/vabs/ibus-pinyin/src/slack-desc

+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.  Line
+# up the first '|' above the ':' following the base package name, and the '|' on
+# the right side marks the last column you can put a character in.  You must make
+# exactly 11 lines for the formatting to be correct.  It's also customary to
+# leave one space after the ':'.
+
+           |-----handy-ruler------------------------------------------------------|
+ibus-pinyin: ibus-pinyin (pinyin engine for ibus input framework)
+ibus-pinyin:
+ibus-pinyin: ibus-pinyin is a Chinese input engine for ibus input framework.
+ibus-pinyin:
+ibus-pinyin:
+ibus-pinyin:
+ibus-pinyin:
+ibus-pinyin:
+ibus-pinyin:
+ibus-pinyin:
+ibus-pinyin:

var/vabs/ibus-qt/src/ibus-qt.SlackBuild

 VERSION=${VERSION:-"1.3.1"}      #Enter package Version!
 VER=$(echo $VERSION|sed 's/-/_/') #this fixes - in version
 VL_PACKAGER=${VL_PACKAGER:-"hata_ph"}   #Enter your Name!
-LINK=${LINK:-""}  #Enter URL for package here!
+LINK=${LINK:-"http://ibus.googlecode.com/files/ibus-qt-1.3.1-Source.tar.gz"}  #Enter URL for package here!
 
 
 #SYSTEM VARIABLES
 LDFLAG_OPTIONS=${LDFLAG_OPTIONS:-""}
 ADDRB=${ADDRB:-""} #Add deps that need to be added to the slack-required file here
 EXRB=${EXRB:-""} #Add deps that need to be excluded from the slack-required file here
+MAKEDEPENDS=${MAKEDEPENDS:-"ibus"}
 #----------------------------------------------------------------------------
 
 

var/vabs/ibus-qt/src/slack-desc

+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.  Line
+# up the first '|' above the ':' following the base package name, and the '|' on
+# the right side marks the last column you can put a character in.  You must make
+# exactly 11 lines for the formatting to be correct.  It's also customary to
+# leave one space after the ':'.
+
+       |-----handy-ruler------------------------------------------------------|
+ibus-qt: ibus-qt (qt library and input method plugin for ibus)
+ibus-qt:
+ibus-qt: ibus-qt includes the ibus qt library and input method plugin.
+ibus-qt:
+ibus-qt: You may need this lib to get ibus fully functional in Qt applications.
+ibus-qt:
+ibus-qt:
+ibus-qt:
+ibus-qt:
+ibus-qt:
+ibus-qt: