Commits

ZyX_I committed f4dc8db

Added README.markdown

  • Participants
  • Parent commits 61b8a16

Comments (0)

Files changed (2)

File README.markdown

+
+
+This plugin provides a vim <--> VCS (mainly mercurial) integration for your 
+projects. Features:
+
+  - Partially committing changes ([:AuRecord](http://vimpluginloader.sourceforge.net/doc/aurum.txt.html#line1221-0))
+
+  - Viewing file state at particular revision ([aurum://file](http://vimpluginloader.sourceforge.net/doc/aurum.txt.html#line1221-0), [:AuFile](http://vimpluginloader.sourceforge.net/doc/aurum.txt.html#line1221-0))
+
+  - Viewing uncommited changes in a vimdiff ([:AuVimDiff](http://vimpluginloader.sourceforge.net/doc/aurum.txt.html#line1221-0))
+
+  - Viewing revisions log ([:AuLog](http://vimpluginloader.sourceforge.net/doc/aurum.txt.html#line1221-0)). Output is highly customizable
+
+  - Viewing working directory status ([:AuStatus](http://vimpluginloader.sourceforge.net/doc/aurum.txt.html#line1221-0))
+
+  - Frontends for various VCS commands
+
+Most commands can be reached with a set of mappings (see [aurum-mappings](http://vimpluginloader.sourceforge.net/doc/aurum.txt.html#line1221-0)), 
+all mappings are customizable.
+
+
+Plugin's mercurial driver is able to use mercurial python API as well as its 
+CLI, but remember that the former is much slower and less tested. In order to 
+use mercurial python API you must have vim compiled with +python (mercurial 
+currently does not support python 3) and have mercurial in python's sys.path 
+(note: on windows msi installer is not adding mercurial to sys.path, so you 
+won't be able to use its python API).
+
+
+Plugin requires some additional plugins:
+
+  — frawor (https://bitbucket.org/ZyX_I/frawor)
+
+(with their dependencies).
+
+
+Note: aurum supports VAM (https://github.com/MarcWeber/vim-addon-manager). It 
+      is prefered that you use it for aurum installation.
+
+
+Documentation is available online at http://vimpluginloader.sourceforge.net/doc/aurum.txt.html.

File doc/aurum.txt

 won't be able to use its python API).
 
 Plugin requires some additional plugins:
-  — frawor
+  — frawor (https://bitbucket.org/ZyX_I/frawor)
 (with their dependencies).
 
+Note: aurum supports VAM (https://github.com/MarcWeber/vim-addon-manager). It 
+      is prefered that you use it for aurum installation.
+
 ==============================================================================
 2. Functionality provided                                *aurum-functionality*