Improve installation section, add explicit yocto/bitbake version to use

Create issue
Issue #21 new
Harald Achitz repo owner created an issue

Since bitbake introduces breaking changes with every (some) version, improve the installation section so it describes how to download and activate the version that works with the tutorial,

also, add some more compatibility notes to this topic