Commits

Alexandre Quessy committed 39b41d3

removed debian-related files from branch 0.0

  • Participants
  • Parent commits f84ec7f
  • Branches 0.0

Comments (0)

Files changed (9)

File debian/control

-Source: python-portmidi
-Section: python
-Priority: optional
-Maintainer: Alexandre Quessy <alexandre@quessy.net>
-Build-Depends: cdbs, debhelper (>= 5.0.38), python-central (>= 0.6.0), python-pyrex, libportmidi-dev, libasound2-dev, python-all-dev
-Standards-Version: 3.8.3
-Homepage: http://bitbucket.org/aalex/pyportmidi/
-
-Package: python-portmidi
-Architecture: any
-Provides: ${python:Provides}
-Depends: ${python:Depends}, ${shlibs:Depends}, ${misc:Depends}, python (>= 2.4), python-central (>= 0.6.7), libportmidi0
-Suggests: timidity, freepats
-Description: Python interface to libportmidi
- pyPortMidi is a Python wrapper for PortMidi. PortMidi is a cross-platform C
- library for realtime MIDI control. Using pyPortMidi, you can send and receive
- MIDI data in realtime from Python. 
- . 
- Besides using pyPortMidi to communicate to synthesizers and the like, it is
- possible to use pyPortMidi as a way to send MIDI messages between software
- packages on the same computer.
- . 
- The original code is from John Harrison.
- See http://python-pyrex.media.mit.edu/~harrison/pyportmidi.html
-

File debian/copyright

-
-This package was debianized by Alexandre Quessy <alexandre@quessy.net> on
-Mon, 15 Mar 2010 12:32:10 -0400
-
-It was downloaded from http://alumni.media.mit.edu/~harrison/code.html
-
-Copyright Holders:
-
- Copyright (c) 2005-2009 John Harrison
-
-License:
-
- Permission is hereby granted, free of charge, to any person obtaining
- a copy of this software and associated documentation files
- (the "Software"), to deal in the Software without restriction,
- including without limitation the rights to use, copy, modify, merge,
- publish, distribute, sublicense, and/or sell copies of the Software,
- and to permit persons to whom the Software is furnished to do so,
- subject to the following conditions:
- 
- The above copyright notice and this permission notice shall be
- included in all copies or substantial portions of the Software.
- 
- Any person wishing to distribute modifications to the Software is
- requested to send the modifications to the original developer so that
- they can be incorporated into the canonical version.
- 
- THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
- EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
- MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
- IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR
- ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF
- CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION
- WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
-
- The text above constitutes the entire PortMidi license; however, 
- the PortMusic community also makes the following non-binding requests:
- 
- Any person wishing to distribute modifications to the Software is
- requested to send the modifications to the original developer so that
- they can be incorporated into the canonical version. It is also
- requested that these non-binding requests be included along with the 
- license above.

File debian/debian-changelog

-python-portmidi (0.0.6-debian10) unstable; urgency=low
-
-  * Splitted changelog for debian/hardy
-  * Moved Suggests to Package section (control)
-
- -- Simon Piette <simonp@sat.qc.ca>  Tue, 23 Mar 2010 17:41:43 -0400
-
-python-portmidi (0.0.6-9) unstable; urgency=low
-
-  * Removed ubuntu mentions, one changelog rules them all
-
- -- Simon Piette <simonp@sat.qc.ca>  Tue, 16 Mar 2010 11:57:31 -0400
-
-python-portmidi (0.0.6-4ubuntu8) hardy; urgency=low
-
-  * Moved dh_installdocs.
-
- -- Simon Piette <simonp@sat.qc.ca>  Mon, 15 Mar 2010 14:25:42 -0400
-
-python-portmidi (0.0.6-4ubuntu7) hardy; urgency=low
-  
-  * Switched to dh_pysupport.
-
- -- Alexandre Quessy <alexandre@quessy.net>  Mon, 15 Mar 2010 12:26:34 -0400
-
-python-portmidi (0.0.6-4ubuntu6) hardy; urgency=low
-  
-  * Fixed ubuntu version number
-
- -- Alexandre Quessy <alexandre@quessy.net>  Tue, 19 Jan 2010 01:35:31 -0500
-
-python-portmidi (0.0.6-0ubuntu5) hardy; urgency=low
-  
-  * Proper Ubuntu packaging.
-
- -- Alexandre Quessy <alexandre@quessy.net>  Tue, 19 Jan 2010 01:25:49 -0500
-
-python-portmidi (0.0.6-4) unstable; urgency=low
-  
-  * Updated libportmidi.a and libporttime.a to the ones in Ubuntu 8.04
-
- -- Alexandre Quessy (SAT) <alexandre@sat.qc.ca>  Mon, 14 Dec 2009 13:48:19 -0500
-
-python-portmidi (0.0.6-3) unstable; urgency=low
-  
-  * Fixed bad error in rules.
-
- -- Alexandre Quessy (SAT) <alexandre@sat.qc.ca>  Mon, 14 Dec 2009 12:46:45 -0500
-
-python-portmidi (0.0.6-2) unstable; urgency=low
-  
-  * Put test_pyportmidi.py in the package's doc.
-
- -- Alexandre Quessy (SAT) <alexandre@sat.qc.ca>  Mon, 14 Dec 2009 12:43:45 -0500
-
-python-portmidi (0.0.6) unstable; urgency=low
-  
-  * Got rid of executables that should not be executables.
-
- -- Alexandre Quessy (SAT) <alexandre@sat.qc.ca>  Mon, 14 Dec 2009 11:46:39 -0500
-
-python-portmidi (0.0.5) unstable; urgency=low
-  
-  * Initial packaging. 
-
- -- Alexandre Quessy (SAT) <alexandre@sat.qc.ca>  Mon, 14 Dec 2009 11:06:08 -0500

File debian/hardy-changelog

-python-portmidi (0.0.6-hardy10) unstable; urgency=low
-
-  * Splitted changelog for debian/hardy
-  * Moved Suggests to Package section (control)
-
- -- Simon Piette <simonp@sat.qc.ca>  Tue, 23 Mar 2010 17:41:43 -0400
-
-python-portmidi (0.0.6-4ubuntu8) hardy; urgency=low
-
-  * Moved dh_installdocs.
-
- -- Simon Piette <simonp@sat.qc.ca>  Mon, 15 Mar 2010 14:25:42 -0400
-
-python-portmidi (0.0.6-4ubuntu7) hardy; urgency=low
-  
-  * Switched to dh_pysupport.
-
- -- Alexandre Quessy <alexandre@quessy.net>  Mon, 15 Mar 2010 12:26:34 -0400
-
-python-portmidi (0.0.6-4ubuntu6) hardy; urgency=low
-  
-  * Fixed ubuntu version number
-
- -- Alexandre Quessy <alexandre@quessy.net>  Tue, 19 Jan 2010 01:35:31 -0500
-
-python-portmidi (0.0.6-0ubuntu5) hardy; urgency=low
-  
-  * Proper Ubuntu packaging.
-
- -- Alexandre Quessy <alexandre@quessy.net>  Tue, 19 Jan 2010 01:25:49 -0500
-
-python-portmidi (0.0.6-4) unstable; urgency=low
-  
-  * Updated libportmidi.a and libporttime.a to the ones in Ubuntu 8.04
-
- -- Alexandre Quessy (SAT) <alexandre@sat.qc.ca>  Mon, 14 Dec 2009 13:48:19 -0500
-
-python-portmidi (0.0.6-3) unstable; urgency=low
-  
-  * Fixed bad error in rules.
-
- -- Alexandre Quessy (SAT) <alexandre@sat.qc.ca>  Mon, 14 Dec 2009 12:46:45 -0500
-
-python-portmidi (0.0.6-2) unstable; urgency=low
-  
-  * Put test_pyportmidi.py in the package's doc.
-
- -- Alexandre Quessy (SAT) <alexandre@sat.qc.ca>  Mon, 14 Dec 2009 12:43:45 -0500
-
-python-portmidi (0.0.6) unstable; urgency=low
-  
-  * Got rid of executables that should not be executables.
-
- -- Alexandre Quessy (SAT) <alexandre@sat.qc.ca>  Mon, 14 Dec 2009 11:46:39 -0500
-
-python-portmidi (0.0.5) unstable; urgency=low
-  
-  * Initial packaging. 
-
- -- Alexandre Quessy (SAT) <alexandre@sat.qc.ca>  Mon, 14 Dec 2009 11:06:08 -0500

File debian/karmic-changelog

-python-portmidi (0.0.6-karmic10) unstable; urgency=low
-
-  * Splitted changelog for debian/hardy/karmic
-  * Moved Suggests to Package section (control)
-
- -- Simon Piette <simonp@sat.qc.ca>  Tue, 23 Mar 2010 17:41:43 -0400
-
-python-portmidi (0.0.6-4ubuntu8) hardy; urgency=low
-
-  * Moved dh_installdocs.
-
- -- Simon Piette <simonp@sat.qc.ca>  Mon, 15 Mar 2010 14:25:42 -0400
-
-python-portmidi (0.0.6-4ubuntu7) hardy; urgency=low
-  
-  * Switched to dh_pysupport.
-
- -- Alexandre Quessy <alexandre@quessy.net>  Mon, 15 Mar 2010 12:26:34 -0400
-
-python-portmidi (0.0.6-4ubuntu6) hardy; urgency=low
-  
-  * Fixed ubuntu version number
-
- -- Alexandre Quessy <alexandre@quessy.net>  Tue, 19 Jan 2010 01:35:31 -0500
-
-python-portmidi (0.0.6-0ubuntu5) hardy; urgency=low
-  
-  * Proper Ubuntu packaging.
-
- -- Alexandre Quessy <alexandre@quessy.net>  Tue, 19 Jan 2010 01:25:49 -0500
-
-python-portmidi (0.0.6-4) unstable; urgency=low
-  
-  * Updated libportmidi.a and libporttime.a to the ones in Ubuntu 8.04
-
- -- Alexandre Quessy (SAT) <alexandre@sat.qc.ca>  Mon, 14 Dec 2009 13:48:19 -0500
-
-python-portmidi (0.0.6-3) unstable; urgency=low
-  
-  * Fixed bad error in rules.
-
- -- Alexandre Quessy (SAT) <alexandre@sat.qc.ca>  Mon, 14 Dec 2009 12:46:45 -0500
-
-python-portmidi (0.0.6-2) unstable; urgency=low
-  
-  * Put test_pyportmidi.py in the package's doc.
-
- -- Alexandre Quessy (SAT) <alexandre@sat.qc.ca>  Mon, 14 Dec 2009 12:43:45 -0500
-
-python-portmidi (0.0.6) unstable; urgency=low
-  
-  * Got rid of executables that should not be executables.
-
- -- Alexandre Quessy (SAT) <alexandre@sat.qc.ca>  Mon, 14 Dec 2009 11:46:39 -0500
-
-python-portmidi (0.0.5) unstable; urgency=low
-  
-  * Initial packaging. 
-
- -- Alexandre Quessy (SAT) <alexandre@sat.qc.ca>  Mon, 14 Dec 2009 11:06:08 -0500

File debian/package.docs

-debian/copyright
-COPYING
-README.txt
-test_pyportmidi.py

File debian/pyversions

-2.4-2.6

File debian/rules

-#!/usr/bin/make -f
-
-# See http://svn.debian.org/viewsvn/collab-maint/deb-maint/python-support/trunk/README
-PYVERS=$(shell pyversions -vs)
-
-# those takes care of default rules 
-DEB_PYTHON_SYSTEM= pysupport
-include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/class/python-distutils.mk
-
-build: $(PYVERS:%=build-python%)
-	touch $@
-
-build-python%:
-	python$* setup.py build
-	touch $@
-
-install: build $(PYVERS:%=install-python%)
-
-install-python%:
-	python$* setup.py install --root $(CURDIR)/debian/python-portmidi
-
-binary-arch/python-portmidi::
-	dh_pysupport
-binary-install/python-portmidi::
-	dh_installdocs -A README.txt test_pyportmidi.py

File makedeb

-#!/bin/bash
-
-# This script will symlink debian/debian-changelog or debian/ubuntu-changelog to 
-# debian/changelog before building the package.
-
-if [ ! -d debian ]
-then 
-    echo "Usage: $(basename $0) distro"
-    echo "Run from an extracted debian package source"
-    exit 1
-fi
-
-if [ $# -lt 1 ]
-then
-    echo "$(basename $0) will make either a debian or ubuntu package"
-    echo "Usage: $(basename $0) distro"
-    exit 1
-else
-    distro="$1"
-    shift
-    echo "$@"
-fi
-
-if [ -f debian/changelog ]  && [ ! -L debian/changelog ]
-then
-    echo "debian/changelog not a symlink"
-    exit 1
-fi
-    
-if [ ! -f "debian/$distro-changelog" ]
-then
-    echo "debian/$distro-changelog: no such file"
-    exit 1
-fi
-
-pushd debian
-ln -sf $distro-changelog changelog
-popd
-dpkg-buildpackage -r $@