HTTPS SSH





This is a demo project: It demonstrates the error I think I'm seeing
with Kafka 0.7 

I have a hard requirement regarding this version of kafka and can't
upgrade willy nilly. 


To run this project, please invoke the following on the command line:

mvn clean install exec:java

Consecutive runs can be executed via 

mvn exec:java


PREREQUISITES: 

 - 1. Download and install kafka version 0.7
 - 2. run kafka -- see kafka project for details (is simple)




NOTE:

 - 1. Please run twice:
 - - a. Once to generate the data
 - - b. Once to see the problem