Unable to communicate correctly with WDM cameras.

Anonymous avatarAnonymous created an issue

When running on this Vaio, loader outputs:

/home/alvar/Proves/r5u87x# ./loader Searching for device... Found camera : 05ca:1830 Firmware : ucode/r5u87x-05ca-1830.fw

Camera reports positive microcode state. Camera reports microcode version 0x0001. Warning: Microcode versions don't match, clearing. Warning: Failed to reset microcode.

Error: Failed to upload firmware to device: Broken pipe (code 32).

Output of lsusb -d 05ca: -vv is attached

Comments (19)

  1. Anonymous

    My apologies, a bug was discovered when the person reported this issue and the file did not get attached. It works now.

  2. Alex Hixon
    • changed status to new
    • changed component to Loader

    Thanks Jesper for that.

    I've sent an email to Sam asking about how the WDM cameras communicate differently from the rest, so stay tuned.

  3. Anonymous

    Here's what happens on my Vaio SZ3XP:

    Searching for device... Found camera : 05ca:1830 Firmware : ucode/r5u87x-05ca-1830.fw

    Camera reports negative microcode state. Sending microcode to camera... Enabled microcode. Camera reports microcode version 0x0100.

    Successfully uploaded firmware to device 05ca:1830!

    Sad to say no creation of /dev/video*

  4. Alex Hixon

    Awesome, so we can upload to WDM cameras now. Regarding the missing /dev/video0, it's not really this tool's job to manage camera/kernel image communication. Take a read of comment 4 of issue 4 for a better explaination of the situation. :)

    I'll just try to get somebody else to reproduce that it works before I close this bug.

  5. Anonymous

    I've tried it again on my Vaio SZ2. Now it reports it loads themicrocode: /home/alvar/Proves/r5u87x# ./loader Searching for device... Found camera : 05ca:1830 Firmware : ucode/r5u87x-05ca-1830.fw

    Camera reports positive microcode state. Camera reports microcode version 0x0100. Not doing anything - camera already setup.

    Successfully uploaded firmware to device 05ca:1830!

    Again no /dev/video, and also: /home/alvar/Proves/r5u87x# ./loader --force-clear Searching for device... Found camera : 05ca:1830 Firmware : ucode/r5u87x-05ca-1830.fw

    Camera reports positive microcode state. Warning: Failed to reset microcode.

    Error: Failed to upload firmware to device: Broken pipe (code -32).

    So perhaps not all is well?

  6. Anonymous

    Hi! Same problem with Vaio SZ1, linux kernel 2.6.27-7 and device 05ca:1830 just "hg clone http://bitbucket.org/ahixon/r5u87x/" 5 minutes ago (so last version!?)

    Also success in uploading the firmware.

    No /dev/video*

    Directly after boot: sudo ./loader --force-clear Searching for device... Found camera : 05ca:1830 Firmware : ucode/r5u87x-05ca-1830.fw

    Camera reports positive microcode state. Warning: Failed to reset microcode.

    Error: Failed to upload firmware to device: Broken pipe (code -32). Hope that helps... Regards

    Vince

  7. Anonymous

    I've got a same behaviour with my Vaio VGN-SZ220, it has

    Bus 001 Device 004: ID 05ca:1830 Ricoh Co., Ltd Visual Communication Camera VGP-VCC2

    on board and while firmware seems to load OK no /dev/video created

  8. Anonymous

    I have the same problem

    r5u87x firmware loader v0.2

    Searching for device... Found camera: 05ca:1832 Camera reports positive microcode state. Camera reports microcode version 0x0100. Not doing anything - camera already setup.

    Successfully uploaded firmware to device 05ca:1832!

    However no /dev/video and force-restart gives the same error as others report

  9. Anonymous

    I'm having the same problem,

    Ubuntu 2.6.27-11-generic, camera is a 05ca:1830 removed from dead viao and connected via usb.

    any pointers on where to look next?

  10. Anonymous

    Hi all,

    There is now a solution to the problem? I have Mint Mate. Linux 3.2.0-23

    $ sudo r5u87x-loader --reload r5u87x firmware loader v0.2

    Searching for device... Found camera: 05ca:1830 Camera reports positive microcode state. Camera reports microcode version 0x0100. Not doing anything - camera already setup.

    Successfully uploaded firmware to device 05ca:1830! Reloading uvcvideo module... Finished.

    ~ $ sudo r5u87x-loader --force-clear

    r5u87x firmware loader v0.2

    Searching for device... Found camera: 05ca:1830 Camera reports positive microcode state. Warning: Failed to reset microcode.

    Error: Failed to upload firmware to device: Broken pipe (code -32). //

  11. Log in to comment
Tip: Filter by directory path e.g. /media app.js to search for public/media/app.js.
Tip: Use camelCasing e.g. ProjME to search for ProjectModifiedEvent.java.
Tip: Filter by extension type e.g. /repo .js to search for all .js files in the /repo directory.
Tip: Separate your search with spaces e.g. /ssh pom.xml to search for src/ssh/pom.xml.
Tip: Use ↑ and ↓ arrow keys to navigate and return to view the file.
Tip: You can also navigate files with Ctrl+j (next) and Ctrl+k (previous) and view the file with Ctrl+o.
Tip: You can also navigate files with Alt+j (next) and Alt+k (previous) and view the file with Alt+o.