Anoter HP Pavilion without /dev/video

Issue #38 duplicate
Anonymous created an issue

Hello, I have the following in my laptop:


Bus 001 Device 002: ID 05ca:1870 Ricoh Co., Ltd

I compiled the loader (commenting out the appropriate line) with the following results:

[root@Pedro r5u87x-f65c81a1980c]# lsmod | grep uvc [root@Pedro r5u87x-f65c81a1980c]#
[root@Pedro r5u87x-f65c81a1980c]#
[root@Pedro r5u87x-f65c81a1980c]# ./loader
Searching for device...
Found camera : 05ca:1870
Firmware : ucode/r5u87x-05ca-1870.fw

Camera reports negative microcode state. Sending microcode to camera...
Enabled microcode.
Camera reports microcode version 0x0112.

Successfully uploaded firmware to device 05ca:1870!

[root@Pedro r5u87x-f65c81a1980c]# lsmod | grep uvc [root@Pedro r5u87x-f65c81a1980c]# modprobe -v uvcvideo insmod /lib/modules/ insmod /lib/modules/
insmod /lib/modules/ insmod /lib/modules/

but no /dev/video is created. Dmesg output:

Linux video capture interface: v2.00 usbcore: registered new interface driver uvcvideo USB Video Class driver (v0.1.0)

FYI the kernel space drivers were working up to kernel 2.6.24 (I believe) but I can't manage to compile them with 2.6.27. If I can help with tests / further infos just ask...

Comments (3)

  1. Pihhan

    Please! try to read comments for similar bugs, before creating new one. Have you tried, after successful firmware loading, first REMOVE not working module uvcvideo (which did hardware detection at time, when no firmware was loaded) using rmmod uvcvideo or modprobe -r uvcvideo? You have to remove module first, because it is loaded by hal on system boot. Only after lsmod | grep uvcvideo will not output anything, you can try load uvcvideo again to see changes. It is unfortunate, but it is only way. I believe it is written in readme, please retry with unloading module first. If you are not root, prepend commands with sudo (usually on ubuntu).

  2. Anonymous

    Thanks for the suggestion. I reckon my above msg was not clear (CR-LF were lost during cut-and-paste) but you should see that there was no uvcvideo already loaded when I loaded the firmware. However I tried this:

    - verified no uvcvideo module loaded - successfully loaded firmware - still no uvcvideo module loaded - manually loaded uvcvideo (this loads also v4l1-compat, videodev, compat_ioctl32) - no /dev/videoX created - manually removed and reloaded all the modules above - still no /dev/videoX

    Any ideas? How can I force HAL to scan hardware again? Thanks

  3. Log in to comment