Plugin 0.0.2 causes a 500 error on redmin 1.4.2

Issue #2 on hold
Anonymous created an issue

After installing the plugin 0.0.2 on Redmine 1.4.2.stable and activate it as a module on one of our projects, i get an internal server error 500 when i try to open the module tab again.

hope you can help us André

-- error when accessing the module page of our project -- Internal error

An error occurred on the page you were trying to access. If you continue to experience problems please contact your Redmine administrator for assistance.

If you are the Redmine administrator, check your log files for details about the error.


Comments (10)

  1. Akiko.T repo owner

    Sorry for my delaying reply. Of cource, I'll do support you as possible as I can, please let me know more information if you don't mind.

    Could you show me the log message when you accesse module tab?

  2. Akiko.T repo owner

    Hello, how is it afterwards? I can run issue_templates ver 0.0.2 on redmine1.4.4.

    Please confirm your migration task, first. And could you show me the log message when you accesse module tab? If you remove redmine_issue_templates plugins from vendor/plugins folder and restart redmine, is the same error still running?

  3. Anonymous

    Hello, My version of redmine is "Redmine 1.4.3.stable (MySQL)" . I am getting the same error.

    I installed the plugin as told in readme.rdoc I stopped my redmine service,copied the folder in vendor.plugins and ran "rake db:migrate" command from teh command prompt and started the redmine service.

    I am getting the 500 error when I start the page itself

  4. Anonymous

    This is what I get when I go to "Settings" tab of redmine (I did not see creation of tables when running db:migrate_plugins) ActiveRecord::StatementInvalid in Projects#settings Showing vendor/plugins/redmine_issue_templates/app/views/issue_templates_settings/_show.html.erb where line #3 raised:

    Mysql::Error: Table 'redmine.issue_template_settings' doesn't exist: SELECT * FROM `issue_template_settings` WHERE (project_id = 14) LIMIT 1

    Extracted source (around line #3):

    1: <div id="issue_templates_settings"> 2: <% 3: @issue_templates_setting = IssueTemplateSetting.find_or_create( 4: %> 5: <p><%= l(:about_help_message) %></p> 6: <% labelled_form_for :settings, @issue_templates_setting,

    Trace of template inclusion: app/views/common/_tabs.html.erb, app/views/projects/settings.html.erb

    RAILS_ROOT: c:/redmine-1.4

  5. Anonymous

    though in the command prompt it says that it is executing create tables, why aren't the tables getting created in the database?

  6. Akiko.T repo owner

    Sorry my delayed reply....

    It seems some tables for issue templates are not exists. As you know, we have to run this command, "rake db:migrate_plugins RAILS_ENV=production", just under the application root directory. After doing this, tables for various plugins are created. Let me confirm you run above command. Note: "rake db:migrate" is only for redmine itself.

    If creating tables for this plugin is success, you can find tables named "issue_templates" and "issue_template_settings", especially in the database for production mode. It seems your error messgae says there is no tables named issue_template_settings, so that I think creating table is not done correctly, or I think RAILS_ENV is different.

    If you don't mind please let me know your nvironment with this command: "ruby script/about ".

  7. Sravanthi Yendluri

    About the application's environment Ruby version 1.8.7 (i386-mingw32) RubyGems version 1.8.16 Rack version 1.1.3 Rails version 2.3.14 Active Record version 2.3.14 Active Resource version 2.3.14 Action Mailer version 2.3.14 Active Support version 2.3.14 Application root C:/redmine-1.4 Environment development Database adapter mysql Database schema version 20120422150750

    About your Redmine plugins Redmine Issue Templates plugin 0.0.2-stable

  8. Akiko.T repo owner

    Please confirm your database not only for development but also production. I wonder you did migration tasks for development mode or not. (Because comment #11 says "Environment development".)

    And I think you have two different databases for Redmine. Please show me the database.yml. (Maybe it 's stored as C:/redmine-1.4/config/database.yml.)

    The migration steps on README of issue_templates is for Production mode. So, you have to start redmine on Production mode. (Exp. ruby script/server -e production.)

    Sorry for my reply is out of line.

  9. Log in to comment