wheezy.html / doc / gettingstarted.rst

Getting Started


:ref:`wheezy.html` requires python version 2.4 to 2.7 or 3.2. It is independent of operating system. You can install it from pypi site using setuptools:

$ easy_install wheezy.html

If you are using virtualenv:

$ virtualenv env
$ env/bin/easy_install wheezy.html

If you would like take a benefit of template preprocessing for Jinja2, Mako, Tenjin or Wheezy.Template engines specify extra requirements:

$ env/bin/easy_install wheezy.html[jinja2]
$ env/bin/easy_install wheezy.html[mako]
$ env/bin/easy_install wheezy.html[tenjin]
$ env/bin/easy_install wheezy.html[wheezy.template]


You can get the source code using mercurial:

$ hg clone
$ cd wheezy.html

Prepare virtualenv environment in env directory

$ make env

... and run all tests:

$ make test

You can read how to compile from source code different versions of python in the article published on mind reference blog.

You can run certain make targets with specific python version. Here we are going to run doctest with python3.2:

$ make env doctest-cover VERSION=3.2

Generate documentation with sphinx:

$ make doc

If you run into any issue or have comments, go ahead and add on bitbucket.