Source / doc / gettingstarted.rst

Getting Started


:ref:`` requires python version 2.4 to 2.7 or 3.2+. It is independent of operating system. You can install it from pypi site using setuptools:

$ easy_install

If you are using virtualenv:

$ virtualenv env
$ env/bin/easy_install

If you would like take benefit of one of cryptography library that has built-in support specify extra requirements:

$ easy_install[pycrypto]


You can get the source code using mercurial:

$ hg clone
$ cd

Prepare virtualenv environment in env directory

$ make env

... and run all tests:

$ make test

You can read how to compile from source code different versions of python in the article published on mind reference blog.

You can run certain make targets with specific python version. Here we are going to run doctest with python3.2:

$ make env doctest-cover VERSION=3.2

Generate documentation with sphinx:

$ make doc

If you run into any issue or have comments, go ahead and add on bitbucket.