Getting more installers

Issue #3 resolved
rgalanakis
created an issue

Hi, I am the maintainer of goless (https://github.com/rgalanakis/goless/). We'd like to set up testing against Stackless Python on Travis, but AFAIK we cannot have custom Python installs (and Stackless isn't available via apt-get, AFAIK). I tried to install stackless-python on Travis and we got the following error (from https://travis-ci.org/rgalanakis/goless/jobs/27487306):

distutils.errors.DistutilsError: Could not find suitable distribution for Requirement.parse('stackless-installer-C4-linux-x86-64>=2.7.6,<2.7.7')

I'm assuming this is because the necessary CPU doesn't have a stackless installer available (I get the same error but for i686 instead of x86-64 locally)? How can new installers be created or provided? Thanks!

We're also tracking this ticket in our repo: https://github.com/rgalanakis/goless/issues/20

Comments (3)

  1. rgalanakis reporter

    Great! Seems to work locally. Will set it up in travis and tox once you get a 33 and/or 34 version so I can remove all of my hackery at once. Tell me if there's anything I can help with.

  2. Log in to comment