Commits

albertoconnor  committed 18d0094

Remove support for Django 1.3 and below by removing verify_exists from a URLField.

  • Participants
  • Parent commits f28d01c

Comments (0)

Files changed (4)

 The primary author of django-mailman is Bernd Schlapsi
 <brot@gmx.info>
 
-The author of this fork is
+The current maintainer is Albert O'Connor 
 <albert@albertoconnor.ca>
 
 Contributors
 `django-mailman` is tested and works with mailman version 2.1.5.
 It's possible that mailman also works with the 2.1.x series, but I guess it wouldn't work with the 3.x series which is under development at the moment
 
-`django-mailman` requires Django 1.0 or later.
+`django-mailman` requires Django 1.4 or later.
 
 Configuration
 =============

File django_mailman/models.py

     name = models.CharField(max_length=50, unique=True)
     password = models.CharField(max_length=50)
     email = models.EmailField(unique=True)
-    main_url = models.URLField(verify_exists=False)
+    main_url = models.URLField()
     encoding = models.CharField(max_length=20, choices=LANGUAGES)
 
     class Meta:
 from setuptools import setup
 
 setup(name = 'django-mailman',
-    version = '0.2',
+    version = '0.4',
     packages = ['django_mailman',],
     platforms = ['any'],
     license = 'GNU LGPL v2.1',
-    author = "Albert O'Connnor",
-    author_email = 'iqc@albertoconnor.ca',
+    author = "Bernd Schlapsi",
+    author_email = 'albert@albertoconnor.ca',
     description = 'Interface to Mailman Web-API',
     long_description = open('README.rst').read(),
     url = 'https://bitbucket.org/albertoconnor/django-mailman',