Compilation Error: GetGLVersion() error (const char *)

Issue #34 resolved
Daniel Guzman
created an issue

Compilation error using: lua LoadGen.lua 2.1 -style=pointer_c -spec=gl -version=2.1 -profile=core

That function:

static void GetGLVersion()
{
    ParseVersionFromString(&g_major_version, &g_minor_version, glGetString(GL_VERSION));
}

Should be:

static void GetGLVersion()
{
    ParseVersionFromString(&g_major_version, &g_minor_version, (const char *)glGetString(GL_VERSION));
}

Thanks!

Comments (2)

  1. Log in to comment