Can't get build to work

Issue #60 wontfix
Brandon Harvey
created an issue

Hi, I'm interested in the "Learning..." book in progress, so I cloned the repo today and installed premake4, lua5, freeglut, and then built tinyxml from within the repo. A few issues stopping progress at this point:

returns

cannot open /home/demo/src/gltut/glsdk/links.lua: No such file or directory

  • I gave get_externals.lua a try, but

lua get_externals.lua

returns

lua: get_externals.lua:20: unexpected symbol near `=='

That's with lua 5. lua 4 returns the following instead:

error: =' expected; last token read:script' at line 2 in file `get_externals.lua'

Comments (2)

  1. Jason McKesson repo owner

    I appreciate the enthusiasm of cloning the repo, but building directly from the repo is not officially supported. In order to do so, you have to either run the `get_externals.lua` script (which requires LuaSocket), or to download the OpenGL SDK found here: https://sourceforge.net/projects/glsdk/ and unzip it into a directory called "glsdk". Then you need to build that with the premake4.lua script in the root of the SDK.

    The supported use of the tutorials is to just use the download, which contains everything you need.

  2. Log in to comment