Problems with frameworkD.lib

Issue #72 resolved
Joseph Ciurej created an issue

Greetings Mr. McKesson,

I've been trying to run through the first of your tutorials to make sure everything was running smoothly following installation. Unfortunately, I've run into a bit of an issue. Whenever I try to run the "Building Triangles" tutorial, I'm met with an error that reads as follows:

"Unable to start program '[file_path]\Tutorial 0.3.8\framework\lib\frameworkD.lib'. The specified file is an unrecognized or unsupported binary format."

I run into similar issues when trying to run the program in the "Test" directory (these are the only two I've tried to run thus far). I used Premake v4 to build the files in both the glsdk directory and the directories where I attempted to run the solution (Tutorial 1 and Test). I most likely made some form of error in setting up the projects, but I can't seem to find it. Do you have any advice? Thanks in advance for your help!

Comments (2)

  1. Jason McKesson repo owner

    I assume you're using Visual Studio or Code::Blocks or an IDE like that (you don't actually say) and you're trying to run one of the tutorial executable from the IDE.

    When you load the solution or workspace or whatever in your IDE, you will see that several projects are loaded. Among these is the project called `framework`. This is a C++ library used by all of the tutorials.

    By default, the `framework` project is the project that will be considered "active" or "start up" when first opening the solution/workspace. The "active" project is the one that will be executed when you tell the IDE to run the program.

    Of course, you can't execute a library, and the `framework` is a library. You have to right-click on the actual tutorial you want to run, and select either "activate project" or "Set as Startup Project", depending on your IDE. Or just right-click on one and tell it to run that one specifically.

  2. Log in to comment